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Introduction

Introduction

LUSAS software is highly customisable. The built-in LUSAS Programmable Interface
(LPI) allows the customisation and automation of modelling and results processing
tasks and creation of user-defined menu items, dialogs and toolbars as a means to
access those user-defined resources. It can also be used for transferring data between
LUSAS and other software applications, and to control other programs from within
LUSAS Modeller, or control LUSAS Modeller from other programs.

LUSAS User Interface

LUSAS Session file

LUSAS LPI

8

LUSAS Modeller

]
1
1 ]
\ VBScript :
]
| 1
1 1
1 ]
1 .NET :
: (c#/vB.NET) W Q
]
1
! |
! 1
! 1
1 \
! |
! 1

Any other COM
compatible
language

LUSAS LPI
LUSAS Extension Modules 3rd Party Software
(Plug-ins) Applications

With LPI, any user can automate the creation of complete structures, either in LUSAS
or from third-party software, carrying out design checks, optimising members and
outputting graphs, spreadsheets of results and custom reports. Because everything
carried out by a user is recorded in a LUSAS Modeller session file, anything that
LUSAS can do, can also be controlled by another application via the LUSAS
Programmable Interface. This means that you can view and edit a recorded session,
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Introduction

parameterise those commands, turn them into sub-routines, add loops and other
functions to the scripts and create a totally different application or program - using the
proven core technology of LUSAS.

In addition to the accessing and customising LUSAS Modeller via the LUSAS
Programmable Interface, user-defined material models (written in Fortran) can be
compiled and built into a customised LUSAS Solver executable by using the LUSAS
Material Model Interface (LUSAS MMI).

Examples of capabilities

Scripts

By using any ActiveX compliant scripting language, such as VB.Net, C#, VBScript,
C++, Python, Perl, JScript etc. to access LUSAS facilities and functionality, you can:

O Create user-defined menu items, dialogs and toolbars
Interrogate all aspects of a LUSAS model

Customise modelling operations

Create parameterised models

Automate repetitive tasks

Import CAD geometry and properties

O 0000 D

Make direct links to Microsoft Word / Excel, or other programs for import or
export of data

(W]

Perform simple / codified design checks and, when used with automated
iterative analysis, optimise structural member sizes and configurations, slab
reinforcement quantities, etc.

In their simplest form script files can be used to store a sequence of LUSAS commands
for later playback. Some examples of use include the creation of start-up templates to
pre-load the Attributes Treeview of the LUSAS Modeller user interface with selected
attributes for a particular analysis; the setting of default mesh or material types, or
preferred colour schemes; or defining specific model orientations for use when saving
model views for use in reports.

When LUSAS is run, a session file is created recording each step of the model
generation in Visual Basic Script (.VBS) - one of the most commonly used and easily
understood languages. Editing of a session file can be used to define a similar model
with new parameters. When the script is re-run in LUSAS, a new user-defined model
can be easily and rapidly generated from the parameters defined. A Macro Recorder
facility in LUSAS also provides the means to record a sub-set of commands for a task,
for saving and re-use. User-generated scripts can be controlled by creating dialogs that
may include parametric variables, check boxes, drop-downs etc.
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Topics covered in this guide

Varied uses of scripts include reading of geometric data, such as column dimensions,
section properties and span lengths / storey heights etc., from a spreadsheet to
automatically build multi-span bridge or building models; rapid generation of
parametrically-idealised wind farm base structures, or for automating the creation of
numerous load combinations and envelopes.

A set of example scripts are provided in LUSAS to assist in the understanding of
standard concepts including file handling, how to access LUSAS geometry / attribute
data, and how to import / export data from / to Microsoft Word or Excel, or other
programs.

Topics covered in this guide

The aim of this guide is to help you locate and use the supplied tools which will enable
you to write scripts and work more efficiently. No programming experience or
knowledge is needed to complete the examples shown. The guide covers:

O Getting started with the LUSAS Programmable Interface (LPI)
Q Identifying LPI Functions

O Customising the interface

O Getting started with VBS

O A simple example script

QO Creating your own menus

LPI Developer Guide
A separate LPI Developer Guide is also available covering more advanced topics:
O Creating dialogs using VB.NET
U LUSAS viaCOM
O LUSAS Material Model Interface
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LPI Command Bar

Getting started with
the LUSAS

Programmable
Interface (LPI)

LPI Command Bar

The LPI Command Bar can be added to the user interface by selecting the menu item
View> LPI Command Bar

6 File  Edit|[View )| Geometry Attributes Analyses Utilities Bridge Composite  Wir
I D& | |¥] Working Mode - @lo-s-0-8-|C
Page Layout Mode g

o utites | [B) Reports

Sl

Layers

=-E3 LPL
=0

Group

Drawing Layers »
[¥] Browse Selection...
[w| Browse Cyclable ltems...

o
2
Tree Frame v
,-!} = = ES' Property Box
B v | LPICommand Bar
¥| Text Qutput
7\ Status Bar
Toolbars...
Show Datatips

L

T

<[ mm

LPI command

Everything that can be selected within LUSAS Modeller can be initiated by typing
commands into the LPI Bar. For instance, when the Save button is selected in LUSAS
Modeller, it is actually calling the function database.save()




Getting started with the LUSAS Programmable Interface (LPI)

B4 LUSAS Bridge Plus - [LUSAS View: LPLmdI W
B4 File Edit View Geometry Attributes

Therefore, to save a model, you can type in the LPI command bar:

call database.save()

and then press Enter:

B

LPI command call database.save()

Commands can also be concatenated using a colon (:) character.
For example:

Txt = "Hello World" : call msgbox (txt)

Identifying LPI functions

There are two ways of identifying which LPI function corresponds to an operation
carried out within LUSAS:

U By writing LPI functions to a file
U By writing LPI functions to the Text Output window.

Writing LPI functions to a file

1. Select the menu item File > Script > Start Recording...
2. Pick menu item(s), for example select Utilities> Vertical Axis and click OK.

3. Select the menu item File > Script > Stop Recording




Identifying LPI functions

A .vbs file will be saved to a chosen location.This file can then be edited with a text
editor to see the LPI commands. An example follows:

SENGINE=VBScript

' LUSAS Modeller session file
' Created by LUSAS 15.2-1cl - Modeller Version 15.2.1601.22607
' Created at 09:53 on Thursday, June 30 2016

' (C) Finite Element Analysis Ltd 2016

v

call setCreationVersion("15.2-1cl, 15.2.1601.22607")

v

'*** Settings/Options/Properties change

call database.setLogicalUpAxis ("Z")

Re-running commands with Modeller

O Commands can be re-run within Modeller by selecting File > Script > Run
Script... and choosing the previously saved .vbs file.

O The Run Script button can also be selected to run scripts.

Writing LPI functions to the Text Output window

1. Select File > Model Properties > Defaults tab > Advanced... > New option...
2. Type echocommands and then click on “Boolean”. Tick the option “Value”.

3. Click OK on all windows.

B4 LUSAS Bridge Plus - [LUSAS View: LPLmdl Window 1]

[Filc] Edit View Geometry Attributes Analyses Utilities Bridge Compesite Window Help Modules Options and Settings =]
POD New. ] g fo~/-0-8~ lZ‘LE The follwing options have been modified s
& open.. a0 | (e =] ED 00
I Close 1 =
Save Cirles Notes | Geometry | Meshing | Attributes [ Solution | Defaults |solvei « [ New Option =
Save As. Symbol defaults = -
= P e—— Name  echocommands
Sze 20 mm  Ange 00  © Otnteger
Manage Results Files. Value |0
. Ao defaults ) String
Script Minimum length 1.0 mm  Advanced settings shouid orly Value
fmport be modified with assistance e
. Maximum length 6.0 o from LUSAS technical support []save changes in moddl fie - o
Import Mesh. value | 0.0
[Advanced...| [ 5ave changes as defaults for new models
Import/Export Model Data... [newopton... | [ Reset | [ pelete | Value!
Export Solver Datafile...
Close Cancel Appl el ok Cancel elp I[ ok [ cancel ] [ ek
5 vodaproperis Ere || | J J [ J
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Getting started with the LUSAS Programmable Interface (LPI)

Now, for every operation carried out within LUSAS Modeller, the corresponding
command will be written to the Text Output window.

For example: If you click on the Save button, you will see the following:

call databa=e. =zawe()
Hodel succes=fully =awed a= C:~LUSAS5151~Project=~MyHodel mdl

LPI command

Details of LPI functions

Details of all LPI functions along with an explanation of what they do, the arguments
they take (if any), the returned values, etc, can be found in the protected User Area of
the LUSAS website. The links that follow can be accessed using the username lusas
and the password powerfulfe

Please refer to the help pages that correspond with your version of LUSAS.

Q http://www.lusas.com/protected/Ipionline/15.0/Ipi.html

Q http://www.lusas.com/protected/Ipionline/15.1/Ipi.html

Q http://www.lusas.com/protected/Ipionline/15.2/1pi.html

LUSAS Programmable Interface (LPI) online help

The left-hand pane of the LUSAS Programmable Interface help system contains a
filtered list of all classes and functions that can be accessed within Modeller.



http://www.lusas.com/protected/lpionline/15.0/lpi.html
http://www.lusas.com/protected/lpionline/15.1/lpi.html
http://www.lusas.com/protected/lpionline/15.2/lpi.html

Details of LPI functions

kanarks
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wians lusas. comjprotectedipionling/ 15.07fi Rl
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2d coordinate object
2dCoords.add
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Coards.distanceFrom Point
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Coords.normalise
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Activate
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Analysis
Analysis Base C
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Lusas Programmable Interface (LPI)

Commonly Used Objects

This section details the abjects that are used most frequently. It is not intended to be exhaustive (see belav)

Modeller - This object represents the currently running instance of modleller. All ather objects are logically children of this object. From here it is
possible to open and access a database. modify the menus. madify the toalbars and similar high level activities. In practice, within a VBSeript. it is not
necessary to refer to the Modleller object as all of its functions appear as global functions.

Database - The database represents the currently apen model file. Generally. abjects within a database are some kind of DatabaselMeniber , Loadset
Attribute or Control .

Databasehlember - points, lines, surfaces, volumes, elements and nodes are all specialised examples of Databaselember . These represent the
physical model.

Loadset - aloadset is a generic term which indludles loadcases. load curves, envelopes, combinations and similar. These are used ta distinguish
between the steps within the analysis

Attribute - loading. materials. slidelines. transformations. and all other objects that appear in the attributes or utilities treeviews in Madeller are all
specialised examples of attribute

Control - contrals are attached to Loadcase objects and contral the analysis. They dictate whether the analysis is linear. non-linear. dynamic etc and
contain the parameters to fine tune such analyses

lew - A view (there ean be several) represents a modeller drawing windou. At any one time only one of them is ‘current’ - which represents the
front-most ane that has the user's attention.

ObjectSet - An object set can contain any number of Databasellember . The selection within a window, the set of visible objects within a window

and user-defined groups are all specialised examples of Objectset

Clicking one of these classes or functions gives a description of the function with its
input arguments and return values in the right-hand pane. Any argument shown in
square brackets is optional.

ignment.addLoadsets pecified
ignment.getAssignmentLoadset
ssignment setLoadset
ignment setloadsetAll
ignment setloadsetFromStart
ignment.setloadsetOff
ignment setloadsetRange
anment setLoadsetSpecified
ignment setLoadsetToEnd
Database countLoadsets
Database createLoadsetTargetValues
Database.deleteLoadset
Database.deleteLoadsets
Database existsLoadset
Database.getLargestLoadsetlD
Database getLoadlset
Database getLoadsets
Database.getsmallestL oadsetlD
Loadset
Loadset Target Values
LoadsetTargetValues.addEntries
LoadsetTargetV alues.addEntry
setTargetValues.addOptimisationCriteria
LoadsetTargetyalues.add OptimisationCriteri
on
LoadsetTargetValues.ad
jsetTargetV alues.
LoadsetTargetyalues.createCambination
LoadsetTargetyalues. createl e
jsetTargetV alues factorLoadcases
LoadsetTargetV alues.getConstantFactors
LoadsetTargetyalues. getEigenvaluelDs
LoadsetTargetValues.getFactorTypes
LoadsetTargetyalues.getH armaniclDs
LoadsetTargetValues.getLoadcaselDs
dsetTargetValues.getOptimisationCriteria

Loa

Marget

Loa

Loadset.createValue

createValue(name, [energy], [foree], length]. [mass], [time], [temperature], [perUnitLength])

Create a new value within this loadset for subsequent use. The initial value will be 0.0 until modified by a call to setValue. LUSAS will not use this value
for any purpose. but will store it in model files. and allow subsequent modification with setValus and/er subsequent access vith getValue. The value
may have any simple data type - integer, boolean. real or string. hut may not he an array. object or other complex type. For numbers, it will often be
desireable but s not compulsary. to attach unit information to the value such that its value can be fetched or modified in a knovm system of units
This is done using the six optional integers. The intagers represent the indices, or ‘power’ of each scalar quantity - e.g. 2=squared,3=cubad and so on
Each integer may be pasitive of negative, E.g. specifying '0.0.1,0.0,0 would mean that the new quantity is a length- 0.0 20,0,0' would mean length
squared ie. area '0.0.1.0-10' would mean length divided by time, ie. velocity: and '0.1-2.0.0.0' would mean force per unit area

name string name of the new value
energy aptional integer energy companent of the new value (default 0.0)

force optional integer force component of the new value (defalt 0.0

length optional integer length component of the new value fdefault 0.0)

mass optional integer mass component of the new value (default 0.0}

time aptional integer time component of the new value (default 0.0}

temperature optional integer temperature component of the new value {default 0.0)

perUnitlength optional integer Only to be used for quantities that are ‘per unit length’ or ‘per unit area’, such as

mm@/m” (default 0.0)
Return value IFDispatch
See alsa setValue getvalue setValueDescription
Back to Loadset

Back to Overview

The creation of a new model will require a call to the Modeller.newDatabase function
and from this other functions may be called to add to, manipulate or interrogate the
state of the objects in the Modeller database.




Getting started with the LUSAS Programmable Interface (LPI)

] Modeller.newDatabase

Global Functions
newDatabase([analysisType], [filename])

Creates a new, blank. model database without saving changes in the previous model. if any. (Use db save first)

analysisType optional string Analysis type to create:. "Structural”. "Thermal”. o "Coupled”
ssignment

ssignment filename optional string Filename to e created. e.g "C:temp\myModelmdr’ If not given. the database will not be

associated with any file until saveAs is callad

. - Return value IFDatabase The new database
ulateAndWriteSection
kEnd

Back to Modeller

get¢mdFileExportData Back to Overvie
lodeller. getCm dFilelmportData

Searching LPI help

Searching of LPI help is possible. For example, a search for “save” will return results
that include the database.save() function:

[= ]

AnalysisBaseClass.deleteSavedArray
AnalysisBaseClass.existsSavedArray
AnalysisBaseClass.saveStrArray

Database.save

AyEIERass save

AnimationView.saveAs 0

Database.deleteSavedArray )

Database.existsSavedArray Save the model to disk.
atabase.savels Arguments none

Database.saveDblArray

Database.savelntArray Return value none

Database.saveStraArray

Database setSaveSafety Back to Database

Graph.savePicture .

GridWindow.saveAllAs Back to Overview

GridWindow.saveAs

BAndnllnr crmnbal il am

Some function basics

Note that the above database.save() function it does not take any parameters and does
not return anything. It simply saves the model.

The database.saveAs(filename) function is an example of a function that does take a

parameter (in this case, just one) comprising a string with the path and file name of the
new model:

10



Details of LPI functions

Database.saveAs

Class.deleteSavedArray
ss.existsSavedArray

aveStrarray Aol
AVeSIrAITa, savels(filename)

As save but allows specification of a new name for the maodel
filename string The path and name of the model file

e
eDblArray
elnthr Return value nane
Back to Database

Back te Overview

GrdWindow.saveAs

To specify that you are passing a string to the function and not any other type of data,
strings need to be placed between double quotes: (“ )

LPI command  call database.saveds("C:\LUSAS 151 \ProjectsMyMewModel,mdl™)

An example of a function that takes one parameter and returns a named attribute:

database.createlLoadingConcentrated ("MyConcentratedLoad")

LPI command  call database. createl oadingConcentrated( My ConcentratedLoad”)

This function creates a concentrated load attribute. The parameter it takes is the name
of the load attribute (for example: MyConcentratedLoad), and it returns an object of the
class ‘Loading Concentrated’:

Database.createLoadingConcentrated

createLoadingConcentrated(attrName)
Creates a concentrated structural loading attribute

attrName string name of attribute
Return value IFLoadingConcentrated newly created attribute

The corresponding entry in the Attributes Treeview is shown as follows:

11
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Layers | Groups | & Attributes | @ Ang
E-3 MyModel.mdl
453 Attributes (1)
Ela Loading {1}
Ela Structural (1)
i 1:MyConcentratedLoad

At the moment this load has a value of 0 for all its components. If you want it to be a
load of, say, 10 units in the X direction, you also need to use one of the functions of the
Loading Concentrated class:

Loading Concentrated

Base Class: Loading

Derived Classes: None

Description

Concentrated structural loading attribute

Available Functions:
setConcentrated(px, py. [pz]. [mx]. [myl, [mz], [loofl], [loof2], [pore])

LPIcommand  call database.createloadingConcentrated("MyConcentratedLoad”).setConcentrated(10.0,0.0)

As stated previously, the parameters in square brackets [ ] are optional, so do not need
to be defined, hence just px and py are specified.

12
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Customising the
user interface

Capabilities

With LPI you can create user-defined menu items, dialogs and toolbars. Dialogs are
covered in the LUSAS Programmable Interface (LPI) Developer Guide. This section
covers customisation of;

U Modifying standard toolbars
O Customised and User toolbar buttons

U Start-up templates

Modifying standard toolbars

Toolbars consist of buttons which can be used to drive the software.
NEEH @ = BB x - &

Within Modeller these can be customised from the View> Toolbars menu item.

13



Customising the user interface

Eé LUSAS Bridge Plus - [LUSAS View: MyModel.mdl Window 1]
Eé File Edit Geometry Attributes  Analyses Utilites Bridge Composite  Window

I @ || Working Mode | 3 |
Page Layout Mode Toolbars
Group » 555 Toolbars: Cloee
Ea MyMo

Drawing Layers L4

Erml
- 7| Browse Selection...

E 7| Browse Cyclable Items...
Tree Frame *
{E L0

Q Property Box
ﬂ '7| LPI Command Bar

I Advanced Defing
| Arimation Builder T
| Annotation Toolz
I WizibilityS election
IkATI P 1

Customize...

Reset

-

IIIIIM1

Help

'7| Text Qutput M zin
v | Status Bar
|'—| ;_ m | Show T oolips Coal Look
oolbars...
= [ Large Buttons

@ Show Datatips

Customized toolbar buttons

Pre-programmed buttons can be added to the toolbars from the View> Toolbars >
Customize > Customize tab, by simply dragging and dropping buttons as required.

Customize @
Customize | User
Categories: Buttons

CRRISEY- 21
NG NS KA (313 E @ E
Rotat d Zo =

Animation Bulder (1 FEXDZM8
Annotation Tools |

Visbilty/Selecior E’b B

Results

IMDPlus
User

Select 3 category, then click a button to see its description. Drag the button
to any toolbar

Description

[ ok || Cancel |[ Hep
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User toolbar buttons

User toolbar buttons can be added and programmed to carry out user defined actions by
navigating to selecting View> Toolbars > Customize > Customize tab and then
selecting User from the Categories list

Customize @

Toolbars | Customize | User

Categories: Buttons
1:2 3 456 7 8 9

Select 5 category, then click a button to see its description. Drag the button

to any toolbar

Description

oK | Coneel | [ Hel

The bitmaps on the toolbar buttons may be changed by modifying the file
C:\<LUSAS Installation Folder>Programs\Config\userToolbar.bmp
Calling functions from user buttons:

The actions carried out when a button on a user tool bar is chosen are defined on the
View> Toolbars > Customize > User dialog.

For example, if you often need to define a concentrated load of, say, 10 in X, 20inY,
and 30 in Z, you can type the LPI function in the user button 1 text box, so that every
time that button was selected, that load attribute would be created in the Attribute
Treeview:

Call database.createlLoadingConcentrated (“TypicalLoad") .set

Concentrated(10,20,30,0,0,0,0,0.0)

Or, if you often want to run a script called MyScript.vbs, then you would type: fileopen
“C:\LUSAS Scripts\MyScript.vbs” user button 2 text box as shown below:

15



Customising the user interface

Customize @
Toolbars I Customize | User

1 cal database createLoadingConcentrated|{" TypicalLoad").s

2 fileopen "CALUSAS Scripts\MyScript.vbs"

o

s
—~ AN “71 =1 | [
a ‘] LY Q]

)
@
3

[
@

e
o

@
o

m
7'
&

@
7'
&

[ ok |[ cance |[ Heb

Adding User buttons to toolbar menus
User buttons can be added to the toolbar menu by dragging and dropping into place.

Help  Modules
IPA IS-TL: cad: K-K-RoEN @(%1 2 )

P
.
Customize @
Toolbars | Customize | User

Categories: =]
Main
Define ] 3 45 6 7 8 9
Advanced Define
View Ltils

Rotate and Zoom

Startup templates

Startup templates can be used to pre-load the Attributes Treeview with selected
attributes for a particular analysis, set default mesh or material types, or define
preferred colour schemes - to name just a few uses.

User-defined startup templates are created by recording the setting of a variety of
selections and then associating the recording with a template name.

You can use any VBS file as a template, and you can also add templates from the “New
Model” form:

16
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New Model Customise Startup Templates ==

File details
Name Location

MyTemplate C:\LUSAS Saripts|MyScript.vbs

File name
Working folder @ Default (7 Current (7) User-defined

Savein C:\LUSAS151VProjects E

Model details

Title

Name  MyTemplate

Timescale units  [Seconds Jobno.
_ _ _ Saript  C:\LUSAS Scripts\MyScript.vbs
Analysis type vertical ais (X (53 @z

= [

Startup template

CK ] [ Cancel ] [ Help ]

Now every time that you create a new blank model, you will be able to choose this
template, which will run the script just after creating the model.

Advanced operations

For more advanced operations a macro facility is available to enable commonly used
commands to be grouped together or abbreviated.

Macro functions should be written in Visual Basic and saved in a file. For example:

sub dp(x,v,2z)

call database.createPoint (x,vy, z)

end sub

The macro file is registered from the Advanced button on the LPI command bar.

LPI cormmand I =l I Advanced..."

The functions in the macro file may then be activated from the LPI command bar by
typing the function name and arguments e.g. dp 1,2,3 or call dp(1,2,3)

17



Customising the user interface
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Capabilities

Getting started with
VBS

LUSAS Modeller records every operation that it carries out in a session file. This file
contains standard calls to LUSAS LPI function in a Visual Basic Script syntax. The file
can be replayed to carry out exactly the same actions again. Alternatively the file can
be modified to carry out different actions.

The procedure is as follows:
1. Tostart by recording a script select File > Script > Start Recording...
2. Carry out a series of operations.
3. Stop recording by selecting File > Script > Stop Recording
4. Edit the .vbs file to cover the cases required.

With a little programming syntax knowledge loops can be used to make the script more
“tidy” and variables can be added to make the script more “flexible”

Editing can be carried out with the standard Windows Notepad (accessible from Start>
All Programs> Accessories> Notepad) or 3 party products such as Notepad++

| MyScript.vbs - Notepad
File Edit Format View Help

SENGINE=VBSCript

' LUSAS Modeller session file

' Created by LUSAS 15.1-2cl - Modeller version 15.1.1617.22304
' Created at 14:52 on Tuesday, February 02 2016

: (C) Fimite Element Analysis Ltd 2016

call setCreationversion("15.1-2cl, 15.1.1617.22304")

‘e | PI Command Bar
call database.createLoadingConcentrated("TypicalLoad").setConcentrated(10.0,2
maxvalue = 20 'maxvalue is a variable that is being assigned the value of 20

For i =1 to maxvalue
MsgBox "Reached " & i & " out of " & maxvalue

Next
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Getting started with VBS

Programming syntax
Some simple rules
e  First line of the visual basic script file must be SENGINE=VBSCRIPT
e Lines to be treated as comments only must start with an apostrophe ()

Basic Operators allowed include:
e Arithmetic: +, -, /, *
e Comparison: =, >, <, >=, <=, <>
e Concatenation: &
e Logical: Not, And, Or
Conditionals

e If..Then... Else

If a > b Then
MsgBox "
Else

d Was

M3gBox "a was nc
End If

e Loops: For ... Next

maxvalue = 20 " max value is a variable that is assigned the value of 20
For 1 = 1 to maxvalue

MsgBox "Reached " & 1 & "out of " & maxvalue
Next

Variables

e Can be strings, numbers etc

e Names must begin with a letter

e Names must not contain an embedded period “.”
e Names must not exceed 255 characters

e Names must be unique

e There is no need to “declare” variables
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Arrays

e  Can contain strings or numbers etc
e Can be “called” individually

o Always use (0) as the first index of the array.

Example:
Dim MyArray(2)
MyArray(0) = 10
MyArray(l) = 20
MyArray(2) = 30

This is a one dimensional array with 3 items. The first element has been assigned a
value of 10, the second 20, and the third 30.

Note that the UBound function returns the largest available subscript of an array:

call msgbox (“Upper bound of array=" & UBound(MyArray))

So the UBound function returns 2 for the array in the example above.

Visual Basic Script online tutorials

More detailed online tutorials showing how to write visual basic script can be found on
the internet. Here are just a few examples:

e English: http://www.tizag.com/vbscriptTutorial/

e English: http://www.tutorialspoint.com/vbscript/index.htm

e  Chinese: http://www.w3school.com.cn/vbscript/
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Simple user script example

Example VB scripts

Simple user script example

Deleting a range of loadcases

In Version 15 of LUSAS the only way to delete loadcases via the user interface was to
click on each of them in turn in the Analyses Treeview and press the delete key. In
Version 16 of LUSAS this is no longer the case.

For Version 15, this manual deletion was easy to do for a small number of loadcases,
but for a larger number was more of an issue. A simple script is to be written to
illsustrate how a range of loadcases can be deleted from the Analyses Treeview.

% LUSAS Bridge Plus - [LUSAS View: Delete Loadcases.mdl Window 1]
[ File Edit View Geometry Attributes Analyses Utilities Bridge Composite Window Help Modules

DW= = e EHEEVEISEY -ElF| igrru:somaes | NEewmw B i
0.0 10 _ 70, _ 30 _ a0 50
Layers | [2] Groups | & Attributes | (2} Analyses | /= Utiities | B Reports -

(=423 Delete Loadcases.md =
3 Structural analyses
E-5 Analysis 1

(1) Geometric
A0 Material E
(D) Liloadcase 1 B
(1) 2:l gadcase 2

(%1 3:Loadease 3

(%1 4L oadease 4 =
(5 5Loadcase 5

(1 6:Loadcase 6

(%) 7:Loadcase 7 =
(% 8:Loadcase 8
(5 9:Loadcase 9 7
(Y 10:Loadcase 10
(1) 11:loadease 11 Y
(Y1 12:L0adcase 12
(5 13:Loadcase 13
(51 14:Loadcase 14
(1) 15:Loadcase 15
(X1 16:L0adcase 16

00

First make a recording
1. Choose File > Start Recording...

Specify a file name
Delete loadcase 1 manually.

Choose File > Stop Recording

a > DN

Open the script file created:
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1 $ENGINE=VBScript
2 ' LUSAS Modeller session file
3 ' Created by LUSAS 15.1-2c¢l - Modeller Version 15.1.1617.22304
- ' Created at 09:21 on Wednesday, February 03 2016
5 ' (C) Finite Element Analysis Ltd 2016
6 T
7 call setCreationvVersion("15.1-2cl, 15.1.1€17.22304™)
o "
10 '*** Delete loadcase/control
11
12 call database.deletelLoadset("Loadczase 17)

In this file note that:
e Line 1: This line is common in all scripts. Do not remove or modify this line.

e Line 7: Specifies the version of LUSAS used to generate the script. This line
is common in all scripts. Do not remove or modify this line.

e Line 12: This is the line that deletes Loadcase 1

e Lines other than those above: These lines are comments: they are ignored.
Comments always start with an apostrophe (°)

If the Loadcase names are of the form Loadcase 1, Loadcase 2 etc and you wanted to
delete Loadcase 2 to Loadcase 50 you need to edit the previous script and insert a
For ... Next loop as seen at the bottom of this next image:

SENGINE=VBScript

' LUSAS Modeller session file

' Created by LUSAS 15.1-2cl - Modeller Version 15.1.1617.22304
' Created at 09:21 on Wednesday, February 03 2016

' (C) Finite Element Analysis Ltd 2016

1

S (s AT 5 Y = U T o B

call setCreationversion("15.1-2cl, 15.1.1617.22304™)
1

o

10 '*** Delete loadcase/control

11

12 For i = 2 To 50

13 call database.deleteLoadset("Loadcase " & 1)
14 Next

Now you are actually calling the deleteloadset function 49 times, taking the argument
Loadcase 2, Loadcase 3, Loadcase 4, etc.
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Simple user script example

Note. The function deletel_oadset is used instead of deletel_oadcase because the
deleteLoadset function also deletes combinations and envelopes.

If you look for information about this function in the LPI online help, you will see that
the loadset can be specified by Loadset name (which is how it has been done in this
example) but it can also be specified by Loadset ID.

Database.deleteLoadset

deleteLoadset{loadset)
deleteLoadset(name, [resFile], [eigen], [harm])

deleteLoadset(ID, [resFile], [eigen], [harm])

Delete the specified loadset. Note that it is not possible to delete results loadcases (close the file instead) or the last remaining pre-processing
Ioadcase.lThe loadset can be specified in several ways, by name, by 1D Iar by type and name/ID. In each case, additionally specifying the results
file name/ID, eigenvalue ID and harmonic ID will clarify to LUSAS which loadset is required. Alternatively, an object may be passed in, which
requires no further clarification. This same principle applies to all functions that input single loadsets, and the examples below reflect this. Each
input form is legal in each circumstance

By ID it would be easier to write the script as follows:

12 For 1 = 2 To 50
13 call database.deletelLoadset (i)
14 Next

And if in the original model you wanted to delete all the even loadcases you would add
‘Step 2’ to line 12:

12 For i = 2 to 100 Step 2
13 call database.deleteLoadset (1)
14 Next

Alternatively if you wanted to delete all the even-numbered loadcases you could
append ‘2T5012°) to the main LPI command:

call database.deleteLoadsets(2T5012)

This would delete from Loadcase 2 to Loadcase 50 in increments of 2.

Save the file as delete_loadcases.vbs
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Example VB scripts

Running a script
A script can be run within LUSAS Modeller as follows:

1. Choose File > Script > Run Script

2. Browse for and select <script_name.vbs>

Supplied script examples

LUSAS supplies many script examples (that are installed as part of a software
installation) which demonstrate how to carry out various functions and tasks. These
may be found at this location;

C:\<LUSAS Installation Folder>\Programs\Scripts\LPIExamples

Q5 (C:) » LUSASIS1 » Programs » scripts » LPIExamples v|€,|

Search LPIExamples

ary = Share with = Burn Mew folder

Name ~  Date modified Type Size

Attributesvbs 30/10/2015 01:35 VBScript Script File 4 KB
Dialogs.vbs 30/10/201501:35 VBScript Script File 2KB
Display.vbs 30/10/2015 01:35 VEScript Script File 3KB
ExportExcelvbs 30/10,/2015 01:35 VBScript Script File 3KB
ExportWord.vbs 30/10,/2015 01:35 VBScript Script File JKB
FileHandling.vbs 301072015 01:35 VEScript Script File 1KE
Geometrywvbs 30/10/2015 01:35 VBScript Script File 2KB
Graphsvhs 30/10/2015 01:35 VBScript Script File 2KB
Groups.vbs 30/10/2015 01:35 VBScript Script File 1KB
ImportExcel.vbs 30/10/201501:35 VBScript Script File 2KB
LPIExampleMenu.vbs 30/10/2015 01:35 VEScript Script File 2KB
Menuswvbs 30/10,/2015 01:35 VBScript Script File 2KB
Mesh.vbs 30/10,/2015 01:35 VBScript Script File 2KB
Results.vbs 301072015 01:35 VEScript Script File 3KB
Selection.vhs 30/10/2015 01:35 VBScript Script File 2KB
TextMessages.vhs 30/10/2015 01:35 VBScript Script File 1KE
UserResults.vbs 30/10/2015 01:35 VBScript Script File 2KB

Note. In the printed versions of the two scripts that follow word wrapping has taken
place. Only lines preceded by an apostrophe (‘) are comment lines. Other lines
containing VB script should not be word-wrapped.

Example script: Attributes.vbs

This supplied script creates a single planar surface and then creates and assigns to that
surface: a regular mesh, material and geometry. A support is created and assigned to a
line; a concentrated load is created and assigned to a point as loadcase 1; and a face
load is created and assigned to a line as loadcase 2.
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Supplied script examples

SENGINE=VBScript

' Create and assign attributes

' Create new database

call newdatabase ()

' Create Surface

call geometryData.setAllDefaults ()

call geometryData.setCreateMethod ("planar")
call geometryData.addCoords (0.0, 0.0, 0.0)
call geometryData.addCoords (40.0, 0.0, 0.0)
call geometryData.addCoords (40.0, 20.0, 0.0)
call geometryData.addCoords (0.0, 20.0, 0.0)

call database.createSurface (geometryData)

' Create Attribute : Surface Mesh 1

call database.createMeshSurface ("Plane
Stress") .setRegular ("QPM8", 0, 0, false)

' Modify selection

call selection.add("Surface", "1")

' Attribute : Plane Stress : Assign to Primary selection
call assignment.setAllDefaults () .setlLoadset ("Loadcase 1")

call database.getAttribute ("Mesh", "Plane
Stress") .assignTo (selection, assignment)

call database.updateMesh ()

' Create Attribute : Isotropic Material 1

set attr = database.createlIsotropicMaterial ("Mild Steel",
200.0E3, 0.3, 7.8E3)

set attr = nothing
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Example VB scripts

' Attribute : Mild Steel : Assign to Primary selection
call assignment.setAllDefaults ()

call database.getAttribute ("Material"™, "Mild
Steel") .assignTo (selection, assignment)

' Create Attribute : Surface Geometric 1

call
database.createGeometricSurface ("Thickness=1") .setSurface (1.0,
0.0)

' Attribute : Thickness=1 : Assign to Primary selection
call assignment.setAllDefaults ()

call database.getAttribute ("Geometric",
"Thickness=1") .assignTo (selection, assignment)

' Create Attribute : Fixed in XY

call database.createSupportStructural ("Fixed in
XY") .setStructural ("R", "R")

' Modify selection

call selection.add("Line™, "4")

' Attribute : Fixed in XY : Assign to Primary selection

call
assignment.setAllDefaults () .setSelectionNone () .addToSelection (
"Line")

call database.getAttribute ("Supports", "Fixed in
XY") .assignTo (selection, assignment)

' Create Attribute : Concentrated Load 1

call database.createloadingConcentrated("Concentrated Load
1") .setConcentrated (0.0, -100.0)

' Modify selection

call selection.add("Point", "3")
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' Attribute : Concentrated Load 1 : Assign to Primary

selection

call
assignment.setAllDefaults () .setSelectionNone () .addToSelection (
"Point") .setLoadset ("Loadcase 1")

' assign load to selected point in loadcase 1

call database.getAttribute ("Loading", "Concentrated Load
1") .assignTo(selection, assignment)

' Define face load

call database.createlLoadingFace ("Distributed 1") .setFace (0.0,
10.0, 0.0)

' Select top face
call selection.remove ("A11l")

call selection.add("Line", "3")

' Create new loadcase and set active

call database.createLoadcase ("Loadcase 2", "Structural")
set loadset = database.getLoadset ("Loadcase 2", "model")
call view.setActiveLoadset (loadset)

set loadset = nothing

' set assignment object with selected face hof and loadcase 2
set hof0 = database.getObject ("Surface", "1")

call assignment.setAllDefaults () .setLoadset ("Loadcase
2") .addHof (hof0)

' assign face load to top face in loadcase 2

call database.getAttribute ("Loading", "Distributed
1") .assignTo(selection, assignment)

Example script: Results.vbs

This supplied script writes a set of results to the text window for a prior selection of
features made in the Modeller view window.
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Example VB scripts

SENGINE=VBScript

' Extracting Results

set textWindow = getTextWindow ()
' set results type
entity="Displacement"
get array of results component names
component=view.getResultsComponentNames (entity)
' extract array of selected nodes
nodes=selection.getObjects ("Node", "A11l")
check nodes in selection
if ubound (nodes) >= 0 then
loop selected nodes
for 1 = 0 to ubound (nodes)
' get node object
set node = nodes (1)
get element Number
num=node.getID()
' write line to text window
text = "Node=" & num
for j=0 to ubound (component)
get averaged nodal result
res=node.getResults (entity, component (j))
text=text & " " & component(j) & " =" & res
next

textWindow.writeLine (text)
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next
set results type
entity ="Force/Moment - Thick Shell"
get array of results component names
component=view.getResultsComponentNames (entity)
extract array of selected elements
elements= selection.getObjects ("Element","All")
loop selected elements
for 1 = 0 to ubound(elements)
set element object
set elt = elements (i)
get element Number
num=elt.getID()
extract array of element nodes
nodes = elt.getNodes ()
loop element nodes
for k = 0 to ubound(nodes)
get node object
set node = nodes (k)
extract node data
nnum = node.getID()
node.getXYZ x,vy,z
get vector of element nodal results
vecRes=elt.getNodeVectorResults (k,entity)
nc=ubound (vecRes)

build output text string
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text = "Elt=" & num & " Node=" & nnum & " x=" & x & " y="
&y & " oz=" & z

for 3 = 0 to nc
text=text & " " & component(j) & " =" & vecRes(j)
next

textWindow.writelLine (text)

next

' extract number of Gauss points
ngp = elt.countGaussPoints ()
' loop gauss points
for k = 0 to ngp-1
vecRes = elt.getGaussVectorResults (k,entity)
nc=ubound (vecRes)

' build output text string

text = "Elt=" & num & " GP=" & k
for j = 0 to nc

text=text & " " & component(j) & " = " & vecRes(7J)
next

textWindow.writeLine (text)
next
next
else

AfxMsgBox "Run an analysis and select some nodes as input to
this script"

end if

32




Supplied script examples

Running a script from a menu

When a number of related scripts have been created it is often more convenient to add a
Modeller menu item to access those scripts, rather than by opening the scripts using the
File > Script > Run Script menu item.

To allow this, one supplied script contains the code to create a menu containing all of
the other supplied scripts. To add the menu item to Modeller’s main menu:

1. Choose File > Script > Run Script

2. Browse to the C:\<LUSAS Installation
Folder>\Programs\scripts\LPIExamples folder

3. Select LPIExamplesMenu.vbs

% LUSAS Bridge Plus - [LUSAS View: MyModel.mdl Window 1]
%F\\e Edit View Geometry Attributes Analyses Utilities Bridge CnmpnslteWmdnw Help

iNEH @ = B E G igsrs + @ 4 Background * [gEl=[mE[Ndle .}m@av
Selection Yellow Selection -
Layers | Groups I& Attributes I (%) Analyses If Utilities | =] Reporls‘ Axes On Thick Black Selection i .
=43 MyModel.mdl N Axes OFff Windows Colours

= D MyModel.mdl Window 1 o

Mesh =i
@ Geometry
@ Attributes

L5 Utlities =1

o

@ Deformed mesh
.4 View properties

=1

This menu script example adds a Test menu name to the main menu, and has a number
of menu items with sub-menus that each trigger a script.

Keeping the LPI menu visible
To keep the LPI menu visible:

1. Open the file C:\<LUSAS Installation
Folder>\Programs\Config\afterNewModel.vbs

2. Add these lines to the bottom of the file:
Scripts= getSystemString("scripts")

call fileopen (scripts&"\LPIExamples\LPIExampleMenu.vbs")

Adding a user menu

A user menu can be added by editing this file in your user folder:
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Example VB scripts

"%USERPROFILE%\Documents\LUSAS160\UserScripts\" -> C:\User\<Your
username>\Documents\LUSAS160\UserScripts\Usermenu.vbs

More advanced scripts

Many more advanced scripts can be downloaded from the protected User Area of the
LUSAS website at:

http://www.lusas.com/protected/download/scripts.html

The username lusas and the password powerfulfe is required to access this page.
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