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Assessment of a 

Composite Bridge 

Deck to Eurocodes 

For LUSAS version: 16.0 

For software product(s):  LUSAS Bridge or LUSAS Bridge plus 

With product option(s): Steel and Composite Deck Designer (PontiEC4 – V3.1) 

With additional software Microsoft Excel installed 

Description  

The global analysis and the assessment of the main girders of a two span continuous 

bridge is to be carried out using the Steel and Composite Deck Designer (PontiEC4) 

software option and LUSAS Bridge. The example is written for use with PontiEC4 

Version 3.1 

The bridge has a symmetrical composite two-girder structure with two spans of 

50.504m. For the purposes of the example the following geometrical simplifications 

have been made: 

 The horizontal alignment is straight 

 The top face of the deck is flat 

 The bridge is straight, that is, not skewed 

 The structural steel main girders are of a constant depth of 2700mm 

Plan, elevation and typical cross section views of the bridge deck are shown on the 

following pages. 
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Plan of left-hand span. 

(Note that transverse ladder bracing is modelled; X-bracing is not modelled.) 

 

Elevation of left-hand span. Right-hand span is similar but handed. 

 

Note.  

 The girder shown above is formed from five Segments (lengths having the same 

beam section size) that are labelled A, B, C, D, and E.  

 Sections are locations defined within a segment at which geometric properties are 

defined or calculated. 

Both terms are used throughout this example. 


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Typical cross section 

The total slab width is 12.75m. The centre-to-centre spacing between the main girders 

is 5.75m and the slab cantilever either side is 3.5m long. The main girder dimensions, 

for each segment, are summarized in the following table. 

 

Table of main girder dimensions 

 

Segment 

name 

Top 

flange 

width 

(mm) 

Top flange 

thickness 

(mm) 

Height 

of 

beam 

(mm) 

Web 

thickness 

(mm) 

Bottom 

flange 

width 

(mm) 

Bottom 

flange 

thickness 

(mm) 

A 600 20 2700 20 1100 20 

C 600 30 2700 22 1100 40 

B 600 30 2700 18 1100 40 

E 600 30 2700 18 1100 50 

D 1100 40 2700 25 1200 50 

 

The slab thickness varies from 0.37m over the main girders to 0.27m at its free edges 

and at its axis of symmetry. For simplification reasons, the actual slab cross-section of a 

half-deck is modelled by a rectangular area, which is the same as the actual width (i.e. 

12.75/2 m), and a second rectangular area modelling the concrete haunch, which has the 

same width as the upper structural steel flange. The equivalent thickness of slab is 

273mm and the equivalent height of the haunch is 75mm. 
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Steel and Composite Deck Designer (PontiEC4 ) 

The Steel and Composite Deck Designer (PontiEC4) is a software option that carries 

out comprehensive calculations for multiple sections on steel/composite bridge decks to 

the Eurocodes. Force and moment results for selected bridge deck elements are 

provided by a corresponding LUSAS model, and loadcase combinations defined within 

LUSAS are associated with design limit states and phases defined in PontiEC4.  

Design calculations covering ULS bending, stress, shear and interaction; SLS stress, 

web breathing and cracking, and fatigue checks for main members and connectors are 

carried out. Results, output in tabbed dialogs, visually show values that pass or fail. 

Graphs and a report containing all input data and output with references to the 

Eurocode clauses can be easily created. 

In the Steel and Composite Deck Designer (PontiEC4) the units in use are always 

indicated in the input and output dialogs, and in general forces are expressed in N 

(Newton), lengths in mm (millimetres), and moments expressed in Nm (Newton 

Metres).  The units used for the LUSAS model will therefore be N, m, kg, s, C. 

Keywords 

Steel, Composite, Deck, Designer, EC4, Design, Checking, Import, Export, ULS, 

SLS, Graphing, Detailed design. 

Method and Objectives 

The main steps in using the Steel and Composite Deck Designer in conjunction with 

LUSAS can be summarized as follows: 

1. Define material and geometric properties in the PontiEC4 Steel and 

Composite Deck Designer. All effective section properties are calculated. 

2. Export the geometric properties from the PontiEC4 Steel and Composite 

Deck Designer for use with a corresponding user-defined LUSAS model. 

3. Use LUSAS to calculate the forces and moments for all the limit state 

combinations. 

4. Export the force and moment data from LUSAS for use in the PontiEC4 

Steel and Composite Deck Designer. 

5. Import force and moment data into PontiEC4 Steel and Composite Deck 

Designer 

6. Assess the results and carry out detailed design checks in PontiEC4  

7. Optimize the structure (by making adjustments to section sizes if necessary) 
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The full interaction between LUSAS Bridge and the PontiEC4 Steel and Composite 

Deck Designer can be seen by referring to the following flowchart.  

 

File types used / generated / saved 

 

LUSAS PontiEC4 

LUSAS Model data (.mdl) PontiEC4 dialog values and settings (.csv) 

Forces and Moment data calculated by LUSAS 

for import into PontiEC4 (.xls) 

Effective geometric section properties data 

calculated by PontiEC4 for import into 

LUSAS (.vbs)  

Saved values and settings made on the Export 

Force and Moment dialog (.inp) 

PontiEC4 analysis log file for all section 

calculations (.log)  
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1. Define material and geometric properties in PontiEC4 

This section covers the definition of material and geometric properties in the PontiEC4 

Composite Deck Designer in order to calculate effective section properties. Once done, 

the beam cross section properties are exported to a VBS file for subsequent importing 

into LUSAS. 

Defining material properties 

To define the required data for this worked example three options are available, 

according to what it is that you need to achieve from carrying out this example. Values 

and settings can be entered into dialogs in three ways: 

 (Option 1) Manually entering all material and geometric data (so that an 

appreciation is obtained for all aspects of using and entering data into the 

various dialogs). This will obviously take the longest of the three options to 

input. See the heading ‘Option 1: Manually entering all material and 

geometric data’ for this option. 

 (Option 2) Loading the material dialog with default values and settings This 

option reduces the material data input, but requires careful checking and 

updating of non-default values and settings in the material dialog as required by 

the example. Geometric data will still need to be entered. See the heading 

‘Option 2: Loading the material dialog with default values’ for this option. 

 (Option 3) Loading all material and geometry data from a csv file (to 

automatically populate the material and geometry dialogs with all the initial 

values and settings required by the example). This is the fastest option and 

would be used if it was simply required to see the main processes and steps 

involved in order to view the results obtained for this example and its 

accompanying LUSAS model. See the heading ‘Option 3: Loading all material 

and initial geometric data from a csv file’, that follows, for this option. 

The example is written assuming that manual entering of all values is done. (Option 1 

above), but option 2 or option 3 will save time in entering data.  

The text that follows, having a grey background, shows the steps required for the three 

options stated. The options are listed in reverse order to the above, according to the 

amount of data entry required, with the least amount of data entry first. 
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Option 3: Loading all material and initial geometry data 

from a csv file: 

A file is supplied if it is desired to automatically populate the material and geometry 

dialogs with the initial values required by the example (as opposed to manually defining 

the values required). 

Associated file 

 Composite_Bridge_Deck_Initial.csv – Contains initial material and 

geometric data / definitions for use with PontiEC4. To use this file: 
 

Run the Steel and Composite Deck Designer (PontiEC4) 

 Run the Steel and Composite Deck Designer (PontiEC4) 

 Select the File > Open menu item, browse for the 

Composite_Bridge_Deck_Initial.csv file, located in the \<PontiEC4  Installation 

Folder>\Help\Examples\LUSAS_Example
 
directory, and click OK. All dialogs 

will be filled with data initially required by the example. 

 Select the File> Save as menu item and save the PontiEC4 dialog data to a 

working project folder different from the PontiEC4 installation folder, (this 

would normally be a project folder in which a LUSAS model would also be created) 

with the name Composite_Bridge_Deck.csv  

 Continue at step 2 in the example entitled ‘Export geometric properties from 

PontiEC4 LUSAS’ 

 

Option 2: Loading the material dialog with default values 

and settings: 

Run the Steel and Composite Deck Designer (PontiEC4) 

 Run the Steel and Composite Deck Designer (PontiEC4) 

 Select the File> New menu item to create a new PontiEC4 project. 

 On the Materials dialog, press the Defaults button. 

 Select the File> Save as menu item to save the PontiEC4 dialog data to a 

working project folder different from the PontiEC4 installation folder, (this 

would normally be a project folder in which a LUSAS model would also be created) 

with the name Composite_Bridge_Deck.csv  


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 Continue at the heading entitled ‘Defining material properties’ checking that each 

dialog panel contains the values that are shown in this example. 

 

Option 1: Manually entering all material and geometric 

data: 

Run the Steel and Composite Deck Designer (PontiEC4) 

 Run the Steel and Composite Deck Designer (PontiEC4) 

 Select the File> New menu item to create a new PontiEC4 project. 

 Select the File> Save as menu item to save the PontiEC4 dialog data to a 

working project folder different from the PontiEC4 installation folder (this 

would normally be a project folder in which a LUSAS model would also be 

created), with the name Composite_Bridge_Deck.csv  

Note. All data entered in the various PontEC4 dialogs will be saved to this file. 

Previously created and saved data, or supplied data (held in .csv files) can be loaded 

into the PontiEC4 dialogs by using the File> Open menu item. 

Defining material properties 

The material dialog is immediately available when you start a new project or when you 

open an existing one. The material dialog is organized into separate panels; Concrete, 

Concrete age, Steel etc.  

 For each panel on the dialog enter the material data shown in the following images. 

Concrete slab 

 


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Concrete age 

 

Notes: 

1. Age of concrete when permanent load is applied 

2. Age of concrete when shrinkage load is applied 

3. Age of concrete when imposed deformations are applied. 

Modular ratios 
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Environment 

 

Imposed strain in the slab 

 

Control of cracking 

 

Shear connection 
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Steel 

 

 Click on the Question mark button  next to the Grade field, to define the Steel 

grade shown. 

Fatigue 
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 2 can be calculated with data input in the window dialog that appears when you 

click on the Question mark button  next to the v,2 input field. In this case, input 

the data below: 

 

 3 can be calculated with data input in the window dialog that appears when you 

click on the Question mark button  next to the v,3 input field. In this case, input 

the data below: 

 

This is the end of the defining materials section. 

Save the data entered 

 Select the File> Save menu item to save the PontiEC4 dialog data to the current 

working project folder. 
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Defining Geometric properties 

Prior to defining the geometric section properties for the spans, the span lengths and the 

effective concrete slab width (beff) of each section, defined at various distances along 

the section, need to be defined. 

Defining shear lag slab and flanges 

 To input data for the effective slab width calculation, select the Utilities> Shear lag 

slab and flanges menu item. 

 Input an array of the bridge spans (the span lengths) in the text box in the top right 

corner: 50.504,50.504 and click on the  button. The X distance where the 

effective slab width changes will be automatically set up in the table 

 For each row input the flange widths b1*, b2*, b0 as 2875, 3500, 500 respectively. 

Note. Values in the table can be selected and copied and pasted into other cells by 

using the context menu. 

 In the Type column ensure that the code 0 is used for the first and last section, 1 for 

the sagging regions, and 2 for the middle support. 

 Click the Calculate button to calculate beff, 

 

 Click the Exit button to close the dialog and return to the material dialog 

Note. Values of effective length Le can be used to manage the shear lag of the 

flanges. 




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Defining geometry for segment A 

The geometric data for each segment and/or section along the bridge now needs to be 

defined starting with segment A. 

 From the main menu select Windows> 2 Geometry to display the Geometry dialog. 

Note at this stage it is not necessary to define all the sections in each segment that will 

be checked; it will be enough to define just one section for each segment, and input a 

distance to automatically obtain the corresponding effective width of slab from the 

shear lag slab table previously defined. 

Note. No entered data is saved with a segment name until the Add to list button is 

clicked. This is done at the end of this section of the example. 

Segment name, sections, x-distances 

 Input the data for the first Segment as shown in the following image. 

 

Structural steel plate details 

 With reference to the main table of girder dimensions, enter the following values: 

 

 Make sure that Top flange in Class 1 is checked (ticked). 

Note. The checkboxes for Top / Bottom flange <40mm should be only checked 

(ticked) for flanges that have a total thickness above 40mm, when they are made up 




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from a number of plates each of a thickness less than 40mm. When done, ultimate and 

yielding tension for steel below 40mm thickness will be used. 

Longitudinal web stiffeners details 

Properties of longitudinal stiffeners are necessary to perform web panel buckling 

calculations. 

 Click the Web stiffeners button and input data as shown in the following image, 

then click OK. 

 

Vertical web stiffener distance 

 

Note.. A vertical stiffeners check is optional and is not carried out in the example. 

Specifying the distance between vertical stiffeners is the only mandatory value in this 

panel. 

 


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Slab concrete 

 In the Slab concrete panel right-click inside the bcls field and select Calculate beff. 

The width of slab will be computed using data previously defined in the shear lag 

table. Input other data as shown in the following image. 

 

For the purposes of this example the section properties of the concrete haunch will be 

ignored in any calculations made, so it is left un-checked. 

Reinforcing bars 

 

Shear connection 
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Fatigue data 

 

 1 can be calculated automatically by clicking the Question mark button  next to 

the input field and then, on the Damage equivalent factor dialog, select the radio 

button for the midspan section and enter 50.5 for the Span length for moments and 

20.2 for the Span length for shears. 
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Detail categories 

 In the Fatigue data panel, select the Detail categories data button and input the data 

as shown on the following image, then click OK. 

 

Adding data for segment A to the segment treeview 

 Click on the Add to list button located under the segment treeview to save all the 

data previously entered for Segment A. 

 Before entering data for other segments, in the segment treeview double-click on 

the name of the segment A. All data previously input is now available for use in 

defining the next section.  

Note. Double-clicking on a segment name in the Segment treeview panel will 

switch PontiEC4 from EDIT MODE to INPUT MODE. The status bar at the 

bottom-left of the screen will always show what mode is being used at any time. 

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Defining Segment C 

 In the Segment name field delete A and type C. Then, with reference to the 

following image, change or ensure that the dialog fields marked have entries as 

shown. Remember that the values of bcls and bsx can be calculated automatically by 

selecting Calculate beff from the context menu for both fields. 

 

 When complete, click the Add to list button to save the data entered. 
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Defining Segment B 

 Ensure that the dialog fields marked have the entries shown. When complete click 

the Add to list button to save the segment data entered. Then define Segment E in 

the same way, again clicking the Add to list button when complete. 

 

Segment E 
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Segment D 

 With reference to the following image change or ensure that the dialog fields 

highlighted have the entries shown. 

 

 Click on the Question mark button  next to the Steel (Bending moment) field and 

specify a support section and a Span length for shears of 50.5 as shown in the 

following image. 
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 When complete click the Add to list button to save the segment data entered. 

Save the entered data 

 Select the File> Save menu item to save the PontiEC4 dialog data to the current 

working project folder. 

2. Export geometric properties from PontiEC4 to LUSAS 

Prior to exporting geometric properties PontiEC4 needs to check that all the data that 

has been input is valid, and then run part of the EC4 code check to calculate the 

required geometric properties of each defined cross section. This is automatically done 

when requesting to view the Results window/dialog and should always be done prior to 

exporting properties subsequently. 

 On the main PontiEC4 menu select Window> 4 Results to set the Results dialog 

active. After a short delay whilst a partial code check is run, the geometric 

properties of each cross section will be calculated. 

 When complete, select File> Export geometric properties to LUSAS 

 Browse to a suitable project folder and enter a filename of “Sections_Rev0.vbs”.  
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 Select (check) all the Export check boxes (apart from Export Phase 2c), select 

(check) Distance middle plane of slab - neutral axis, and select the option 

Assume slab width constant and use minimum value. Click OK to finish. 

 

The file created can be imported into LUSAS to create new, or overwrite any similarly 

named geometric and material properties. Note that Phase 2c relates to prestressing and 

is not required here. 

Discussion: Modelling and Analysis with LUSAS 

Because the primary aim of this example is to show the use of the PontiEC4 Composite 

Deck Designer and the interaction between it and LUSAS, no step by step instruction is 

provided for construction of the required associated LUSAS model.  

Several modelling approaches are possible in order to analyse a structure and obtain the 

forces and moments required for a design check of the composite sections. Possible 

options include grillage, ribbed-plate, or line beam methods. Users can choose the most 

suitable approach to their method of working, and obtain forces and moments as 

required. 

Modelling 

The model supplied for use with this example is a grillage model. Longitudinal grillage 

members have been placed at the location of the two girders and at the deck edges. 

Transverse members have been placed at the locations of the transverse beams and at 

the deck ends. Between the main girders, coincident lines are used to model both the 

transverse beams and the transverse segments of the slab deck separately.  
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Meshing 

BMS3 elements have been used throughout and all mesh lies on the middle plane of the 

slab: the cross sections of the main girders and transverse beams are given an 

appropriate eccentricity within LUSAS. The edge longitudinal lines have a dummy 

cross section and are included in the model to enable processing of the discrete loads. 

The LUSAS model is for a  composite

two-girder, two span structure

For the worked example

the design check carried

out is for a single girder

within the model

 

Geometric properties 

Geometric properties are imported into LUSAS from PontiEC4 for each of the design 

phases considered. Eccentricities for sections are calculated as part of the PontiEC4 

export process, with the mid-plane of the slab sitting on the nodal line if the appropriate 

option was selected during export. In the LUSAS model supplied, these section 

properties have already been assigned to corresponding lines of the model. Note that re-

importing properties of the same name that have already been assigned to a model 

simply overwrites the existing definitions.  

Material properties 

Material properties, whilst defined in PontiEC4 for effective section and other 

calculations, are not imported into the LUSAS model, so when starting a real-life model 

for the first time, these would need to be defined and assigned to relevant features. In 

this example, the required materials have been defined and assigned to the appropriate 

lines. 
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Supports 

Span lengths, whilst defined in PontiEC4, are not imported into LUSAS to derive 

support positions. Instead, suitable supports must be defined within LUSAS and 

assigned to the relevant features of the LUSAS model, In this worked example, all 

supports are fixed in the Z-direction, and have a spring stiffness of 3.03E6 in the X and 

Y directions. 

Analysis 

The LUSAS multiple analysis facility is used, with four separate analyses being defined 

to represent the four design phases that need to be considered. These are: 

1. Phase 1 – Where the slab is present just as weight; the cross sections are 

only steel and not composite. The concreting order of the slab segments has 

been ignored, supposing that the concreting of the slab occurs at the same 

time. 

2. Phase 2a - The composite section has been calculated using the long term 

properties of the concrete, and the long term loadings considered are the 

permanent ones. 

3. Phase 2b - The composite section has been calculated using the long term 

properties of the concrete, and the long term loading considered is the 

shrinkage of the concrete. 

4. Phase 3 - The composite section has been calculated using the short term 

properties of the concrete. All variable actions are considered in this analysis. 

A series of loadcases have been created to represent thermal action, LM1 

Tandem and UDL, fatigue vehicle FLM3 and wind effects. 

Notes 

 Phase 2c in PontiEC4 represents the actions arising from prestressing and is 

therefore not required in this example. 

 Transverse slab sections have been calculated based on the appropriate width 

of slab with appropriate time-dependant concrete properties applied in each 

phase. For the purposes of this example any possible reduction in torsional 

stiffness for these sections is not considered. 

Loading and load cases 

The following table summarizes the loadings and load cases used for each analysis. 

Analysis Loadings Loadcases 

Phase1 

PHASE 1 Longitudinal and transv. beams Weight (m/s^2) 

PHASE 1 Stud Weight (N/m) __for_beam 

PHASE 1 Slab Weight (N/m)__for_beam 

Self_Weight 
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Analysis Loadings Loadcases 
PHASE 1 Curb Weight w=750mm  (N/m)__external_beam 

PHASE 1 Curb Weight w=1500mm  (N/m)__internal_beam 

Phase2a 
PHASE 2a Permanent loading (N/m)__x_external_beam 

PHASE 2a Permanent loading (N/m)__x_internal_beam 
Permanent 

Phase2b 

PHASE2b Internal support settlement Settlement 

Shrinkage_A_S1 

Shrinkage_C_S1 

Shrinkage_B_S1 

Shrinkage_E_S1 

Shrinkage_S_S1 

Shrinkage 

Phase3 

 

PHASE 3a Thermal Heat  Thermal_Heat 

PHASE 3a Thermal Cold  Thermal_Cold 

Tandem1 (Eurocode Load model 1 300000N) 
From ID=2 Pos=1  

to ID=36 Pos=35 

Tandem2 (Eurocode Load model 1 200000N) 
From ID=37 Pos=1  

to ID=71 Pos=35 

Tandem3 (Eurocode Load model 1 100000N) 
From ID=72 Pos=1  

to ID=106 Pos=35 

Udl1 (Eurocode Lane Load 3mx3m Load=9000N/m2) 
From ID=2 Pos=1  

to ID=36 Pos=35 

Udl23 (Eurocode Lane Load 3mx3m Load=2500N/m2) 
From ID=37 Pos=1  

to ID=71 Pos=35 

Udl23 (Eurocode Lane Load 3mx3m Load=2500N/m2) 
From ID=72 Pos=1  

to ID=106 Pos=35 

UdlRA (Eurocode Lane Load 3mx1.5m  Load=2500N/m2) 
From ID=107 Pos=1  

to ID=141 Pos=35 

FLM3 (Eurocode Fatigue Load Model 3 120000N) 
From ID=2 Pos=1  

to ID=36 Pos=35 

PHASE 3b Wind V (N/m)__x_internal_beam 

PHASE 3b Wind V (N/m)__x_external_beam 
Wind 

 

Traffic loading 

The traffic loading has been generated from the vehicle libraries in LUSAS and 

positioned using the Moving Load Generator. LM1 Tandem loadings have been moved 

along the lanes using an incremental distance of 3m. UDL loadings are defined as a 

segment with a length of 3m, and moved along the lanes by an incremental distance of 

3m. (These patches will be combined in Smart Combinations and applied in adverse 

area only) 

The notional lane position for the LM1 has been considered to maximize bending 

moments and shears in the right (external) girder beam. The lane position of the Fatigue 

model loading 3 is the actual position of the heavy traffic lane. 
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Notional lanes for Load Model 1 (ULS and SLS) 

 

 

 

Fatigue Load Model 3 positioning 

Shrinkage 

Shrinkage effects in analysis Phase2b have been calculated applying a thermal gradient, 

equivalent to an imposed curvature. The forces and moments arising from this model 

represent the hyperstatic effect of the shrinkage. The primary effects of shrinkage are 

computed directly in PontiEC4 for each section. 
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Smart combinations 

In order to define the design envelopes for each Phase and for each Limit State the 

following smart combinations have been defined.  

Preliminary combinations 
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ULS design combinations 
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SLS characteristic design combinations 
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SLS frequent design combinations 

 

 

 

 



Assessment of a Composite Bridge Deck to Eurocodes 

 32 

 

 

Fatigue design combinations 

 

 

3. Use LUSAS to calculate the forces and moments for all 

limit state combinations 

Associated Files 

 Sections_Rev0.vbs - A file created by PontiEC4 containing geometric 

section data to import into LUSAS. A version of this file is supplied also, but is only 

for use only in case of difficulties in manually creating the appropriate data 

 Composite_Bridge_Deck.mdl – A supplied LUSAS model file that is to 

be used to analyse the structure. After solving this model, analysis results are 

exported from LUSAS or use in PontiEC4 to undertake design checks. 
 

Open the associated LUSAS model 

 Run LUSAS Modeller and select the File> Open menu item, and open the supplied 

model named Composite_Bridge_Deck.mdl which is located in the \<PontiEC4  

Installation Folder>\Help\Examples\LUSAS_Example
 
directory. 

 Select the File> Save as menu item and save the LUSAS model data to the same 

working project folder as that used to save the PontiEC4 dialog data earlier) 

keeping  the same file name Composite_Bridge_Deck.mdl 


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Importing the section properties from Ponti EC4 

 Select File> Script> Run Script and select the PontiEC4 script file 

“Sections_Rev0.vbs” that was created in the working project folder earlier. This 

imports the geometric section data from PontiEC4.  

Note. In this worked example, the geometric beam properties calculated by Ponti EC4 

have already been assigned to the relevant lines in the supplied LUSAS model, so re-

importing properties of the same name that have already been assigned simply 

overwrites the existing definitions. When importing geometric properties for the first 

time on a real project, the attributes created would need to be assigned to relevant lines 

of your model. Cracked section properties would be assigned to appropriate lines in the 

LUSAS model in accordance with the requirements of the code. 

 In the Analyses treeview  notice 

that different geometric assignments 

have been made for the main girders 

and material assignments for the slab 

for each analysis to represent the 

various design phases. 

 Press the Solve button  to 

compute all loadcases in all the 

analyses.  

 

The model contains a large number of loadcases. After a short wait whilst they are all 

evaluated, results will be obtained. 

4. Export the force and moment data from LUSAS 

Selection of elements for checking 

To enable design checks to be carried out the start and end elements of each main 

girder segment need to be selected. For this example, various deck members as well as 

the elements at the start and end of each main girder segment have been pre-selected 

and stored as separate Groups. 

The model has been saved with group name “Half_External_Beam” (as seen in the  

Groups treeview  ) Set as Only Visible. 

 In the Groups treeview  right-click on the group name “Selected_Elements” and 

select the Select Members menu item. These elements selected are those that occur 

at the changes of geometric section, and they represent the sections at which design 
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checks will be undertaken in PontiEC4. Note that re-meshing of the model may 

renumber elements and prevent the automatic selection of required elements by use 

of this Group name. If this was to occur a manual selection of these elements would 

have to be done. 

If fleshing of assigned geometric properties was turned on prior to the above, the 

elements selected would appear like this, showing that they occur at the start and end of 

each main girder segment: 

 

Note. The required element selections shown above can otherwise be achieved on a 

fleshed model by selecting the Geometric Properties dialog option Colour by> 

assignment and then selecting the  Geometry menu item to show the geometric 

sections and using the Select Elements toolbar button  to only select the elements 

required.  

 To export the information for these sections, select the Design> Export to 

Composite Deck Design…menu item. 

 In the Analysis selection dialog that appears, select Phase 3 from the drop-down list 

provided, and click OK. The geometric properties assigned to Phase3 will be used 

to determine the section details for export. 

 

 On the Export Forces and Moments dialog, select the Selected Sections tab. These 

sections have been defined based on the elements selected prior to selecting the 

Bridge> Composite Deck Designer> Export… menu item. 
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For each selected element, the table defines two sections, representing the first and last 

Gauss points. Each Section name listed has the following information: Element 

(number), Gauss point (number), Cracked/uncracked section status.  

The section names in this table are created from the following named objects/values in 

the LUSAS model: 

“[Segment Name]+“_”+ “[Element number]+“_”+[Gauss Point Number] 

Important. The Export Forces and Moments facility obtains the segment and 

the phase name from the name of the assigned geometric attribute, by splitting the 

attribute name on the double underscore separator “__”. For this reason the 

cross-section geometric properties in any associated LUSAS model must have a 

name that follows this standard:  

[Segment Name] +”__”+ [Phase name]; where the phase name should be: {F1, 

F2a, F2b, F3a, F3b, cracked}. 

The cracked status of the section is a Boolean value taken as true when the phase 

name is “cracked”, and false otherwise. 

 

 Click the “Loadcase Details” tab. 
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On the Loadcase Details tab the design combinations, design limit states and phases are 

to be stated, along with the specification of shrinkage/thermal coefficients and 

component values of interest. 

 

To assemble a design combination, proceed as follows: 

 In the left-hand panel select ULS_Fundamental_Phase1, select a Design limit state 

of ULS_Fundamental, and from the Phase drop-down list select Phase 1. Click the 

Add to button  to add the design combination to the right-hand panel 

 Repeat the above sequence for all combinations listed in the table that follows, 

selecting the corresponding Design limit state and Phase for each one. 

 

Loadcase Design limit state Phase 

ULS_Fundamental_Phase1 ULS Fundamental Phase 1 

ULS_Fundamental_Phase2a ULS Fundamental Phase 2a 

ULS_Fundamental_Phase2b ULS Fundamental Phase 2b 

ULS_Fundamental_Phase3a ULS Fundamental Phase 3a 

ULS_Fundamental_Phase3b ULS Fundamental Phase 3b 

SLS_Characteristic_Phase1 SLS Characteristic Phase 1 

SLS_Charactersitic_Phase2a SLS Characteristic Phase 2a 
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Loadcase Design limit state Phase 

SLS_Characteristic_Phase2b SLS Characteristic Phase 2b 

SLS_Characteristic_Phase3a SLS Characteristic Phase 3a 

SLS_Characteristic_Phase3b SLS Characteristic Phase 3b 

SLS_Frequent_Phase1 SLS Frequent Phase 1 

SLS_Frequent_Phase2a SLS Frequent Phase 2a 

SLS_Frequent_Phase2b SLS Frequent Phase 2b 

SLS_Frequent_Phase3a SLS Frequent Phase 3a 

SLS_Frequent_Phase3b SLS Frequent Phase 3b 

SLS_Frequent_Phase1 Fatigue Phase 1 

SLS_Frequent_Phase2a Fatigue Phase 2a 

SLS_Frequent_Phase2b Fatigue Phase 2b 

SLS_Frequent_Phase3a Fatigue Phase 3a 

Fatigue_Phase3b Fatigue Phase 3b 

 

Note that loadcase SLS_Frequent_Phase3b is not mapped as a Fatigue design limit 

state; the Fatigue_Phase3b loadcase must be mapped instead. 

 Input a Shrinkage coefficient of 1.2 for the ULS, and 1.0 for the SLS.  

 Remove the default thermal coefficient values that are present and enter values of 

0 for both the ULS and SLS Thermal coefficients  

Note. These coefficients will be applied to the characteristic primary effects of the 

shrinkage as directly calculated in PontiEC4. The isostatic effect will be neglected 

(=0) in the cracked section (True in cracked column of the Section Table column). 

The hyperstatic effect of the shrinkage comes from the LUSAS model and the 

combination factors have been already applied in the LUSAS smart combinations.  

 In the Component to maximize/minimize panel ensure Fz and My are checked. 

(These are the components that will be considered in the smart combinations) 

 Click the ellipsis button  to choose the folder and name of the xls file to create 

(e.g.: <current work directory>\Forces_and_moments.xls), pressing the Save 

button to return to the main dialog 

 Click the Save button on the bottom-left of the dialog to save the data entered in the 

dialog pages for any possible re-use. Save the input as 

“Export_Forces_to_PontiEC4.inp”.  

 Then, finally, click OK to create the XLS file for use in PontiEC4. 
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5. Import force and moment data into PontiEC4 

Associated File 

This supplied file is only for use in case of problems in manually creating the 

appropriate data in the previous section of the example. 

 Forces_and_moments.xls  File created by the LUSAS Export Forces 

and Moments dialog containing data to import into PontiEC4. 
  

Importing force and moment data into PontiEC4 

This section covers the import of section force and 

moment data from LUSAS into PontiEC4. Refer to 

the “Forces and moments” section in the PontiEC4 

online help file for more information.  

Whilst it is possible to manually enter forces and 

moments into PontiEC4 in the “Forces and 

moments” dialog, and it is also possible to copy and 

paste data into each section, when used with LUSAS 

any importing of data is far better achieved by using 

the automated procedure as follows. 

 In PontiEC4, with the current data still loaded (or with the data from the previously 

saved file “Composite_Bridge_Deck.csv” loaded if the example had been saved 

and closed for some reason at that point), select the File> Import forces/moments 

menu item and load the file Forces_and_moments.xls from working project folder. 

PontiEC4 will detect that 32 additional sections are present (these are the sections at the 

beginning and end of each beam element that was selected to signify a change of cross-

section geometric property in the LUSAS model) and ask if they are to be added to their 

corresponding segments.  

 Click Yes to import the new sections. This operation may take a few seconds to 

complete. The status bar will show the progress. 

 From the main menu select Windows> 2 Geometry to display the Geometry dialog. 

In the Segment treeview the new sections added to each segment can be seen.  

 If any previously defined initial sections for each segment (named “S1”) are present 

these are no longer necessary and should be deleted. To do this, select each section 

named S1 in turn, click the right-hand mouse button, and choose Delete. 

Note. If any mistakes are made in deleting the unwanted sections, a re-import of 

the forces_and_moments.xls file will re-insert any deleted sections. 


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 Select File> Save As and enter a file name of Composite_Bridge_Deck.csv to save 

the PontiEC4 dialog data to the working project folder before proceeding to 

view the results.  

This concludes the data input. 

6. Assess the results and detailed design checks in PontiEC4 

This section focuses on the procedure required to assess the main girder beams for 

Ultimate, Serviceability, and Fatigue limit states. It involves: 

1. Viewing utilisation factors for all checks performed 

2. Updating section sizes for any over-utilised sections 

3. Viewing updated results 

4. Updating the LUSAS model and re-analysing the revised sections 

It is usually enough to cycle through steps 1 to 4 once, or perhaps twice, to obtain an 

optimized structure. 

Limited details have been given about all the checks that are carried out. To find out 

more about the checks performed refer to the PontiEC4 online Help, where design code 

and theory details are also supplied. 

Viewing results in PontiEC4 

 With the results loaded in PontiEC4 select the Window> Summary of results. 

menu item. This carries out the design computations in PontiEC4 and displays the 

results for deck sections in a summary form.  

The meaning of the coloured utilization factor entries is explained in the following 

table: 

Colour of value / text Utilization factor Meaning 

Red Greater than 1.0 Value has failed the check carried out. 

Green  Less than 1.0 Value has passed the check carried out. 

Grey - without parentheses Any Value of potential interest but the utilisation factor 

is not relevant to the code.  

(Grey) - with parentheses Any Value of potential interest but the utilisation factor 

is not relevant to the code in this particular context. 

Grey stating ‘No int.’ Not applicable No interaction between bending and shear. 
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A check of the utilization factors obtained should be made for each limit state. Only a 

check for the Fundamental ULS combination will be shown here.  

Note. By clicking on a particular header the values in a column can be sorted in 

increasing or decreasing value. Sort the SigEd/fy column. It can be seen that Segments 

D and C fail the check for normal stresses at ULS, as shown below. 

 

Note. Changing from the Geometry, Materials or Forces and moments dialogs to the 

Results, Summary of results, Report, or Cracking dialogs causes a re-analysis of results. 

 Select the Window> Results menu item in order to find out more about the failed 

checks.  

 In the Cross-sections and design combinations panel select section D_50_11 and 

Fund. ULS, Mmax 

      

 Then, in the lower part of the Results dialog, select the Stresses tab and look at 

Stresses of effective cross section 


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Note.  Currently,  the stresses tables contain non-English abbreviations in their header 

that need to be explained: ‘F1’, ‘F2a’, ‘F2b’ etc come from the Italian ‘Fase’ – meaning 

‘Phase’ in English, as in Phase 1, Phase 2 etc. ‘N.F.’ is the Italian abbreviation for ‘Non 

Fessurata’ – meaning ‘Not Cracked’, and ‘F’ denotes ‘Fessurata’ – meaning ‘Cracked’. 

Phase totals listed are a summation of all the Cracked values for each Phase. 

The normal stresses are very large in the bottom flange where they exceed fy. They are 

also quite large in the top flange. 

 Select the Plastic check tab to view the classification of the section (Class 4). 

 

7. Optimize the structure 

Associated Files 

These supplied files are only for use in case of problems in manually creating the 

appropriate data in this section of the example. 

 Composite_Bridge_Deck_Optimized.csv - the input file for 

PontiEC4 with updated steel flange values for segments D and C. 


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 Sections_rev1.vbs - A file created by PontiEC4 containing revised section 

data to import into LUSAS to update the geometric properties in the LUSAS 

model. 
  
For this example, optimizing the structure involves making changes to flange plate 

thicknesses in the PontiEC4 Composite Deck Designer for those segments that failed 

the design check, then using LUSAS to calculate revised forces and moments, and then 

re-assessing the revised results and design checks in PontiEC4. 

Revise selected flange thicknesses in PontiEC4: 

Flange thicknesses will be increased on those segments that currently fail the check for 

normal stresses at ULS. 

Segment D 

 In PontiEC4, select the Window> Geometry menu item, and then select Segment D 

in the segment treeview. The status bar should state : “Edit GEOMETRY of 

Segment D” 

 Increase the top flange thickness (ts) from 40 to 50 

 Increase the bottom flange thickness (ti) from 50 to 80 

 Select the Window> Results menu item and view the updated results for Section 

D_50_11 and Fund. ULS Mmax.  

Because of the modification to Segment D, the Plastic check dialog will show that it 

has now moved from Class 4 to Class 3. As a result, the stresses of effective cross 

section radio button will no longer be available on the Stress results page of the Results 

dialog. 

Note. Effective stresses are available only for the Class 4 sections.  

 Select the Stresses tab and look at Stresses of gross cross section 
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The flange thickness changes for Segment D now allow it to pass the design check. 

Segment C 

 Select the Window> Geometry menu item, and then select Segment C in the 

segment treeview. The status bar should state : Edit GEOMETRY of Segment C 

 Increase the top flange thickness (ts) from 30 to 50 

 Increase the web thickness (twr) from 22 to 25 

 Increase the bottom flange thickness (ti) from 40 to 60 

 Select the Window> Results menu item and view the updated results for Section 

C_46_11 and Fund. ULS Mmax. The flange thickness changes for Segment C now 

allow it to pass the design check. (And selecting the Plastic check tab would show 

that it, too, has moved from Class 4 to Class 3). 

 

 Select the Window> Summary of results menu item. Sort the SigEd/fy column. It 

can be seen that Segments D and C now both pass the check for normal stresses at 

ULS, as shown below. Stresses for other combinations are all satisfactory. 

 

 Select File> Save As to save the current PontiEC4 project data as 

Composite_Bridge_Deck_Optimized.csv.  
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Export the revised geometric data to LUSAS 

 Select the File> Export geometric properties to LUSAS menu item. Ensure that 

the destination directory is set to the working project folder, and input a filename of 

Sections_Rev1.vbs. Then select (check) all the Export option boxes (apart from 

Export Phase 2c), select (check) Distance middle plane of slab – neutral axis, and 

select the option Assume slab width constant and use minimum value. Click OK 

to finish. 

 

Calculate revised forces and moments in LUSAS 

 In LUSAS, and with the Composite_Bridge_Deck.mdl file open, select File> 

Script > Run Script and from the working project folder select the PontiEC4 script 

file Sections_Rev1.vbs to import the optimized sections into the model. The new 

sections will overwrite the geometric and material properties previously used. 

 Select the File> Save As menu item to save the model to the working project folder 

as Composite_Bridge_Deck_Optimized.mdl and click Yes to close all open 

results files. 

 Press the Solve button  to compute all loadcases in all the analyses. After a 

short wait the solving will be completed. 

Export the revised force and moment data from LUSAS 

This involves repeat the operations from Step 4 in this example. In summary, this 

involves: 

 In LUSAS, select those elements of interest at the start and end of each main girder 

segment, and export the results for those elements by selecting the Design> Export 

to  Composite Deck Design… menu item (they may still be selected). 
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 Ensure that Phase 3 is chosen, and when the Export Forces and Moments dialog 

appears press the Open button to populate the dialog with previously saved entries 

from the Export_Forces_to_PontiEC4.inp file that related to the loadcase 

mapping and other settings.  

 Then, on the same dialog, click the ellipsis button  to choose the folder and 

name of the xls file that should be created (e.g.: Forces_and_moments_rev1.xls), 

and press Save to return to the main dialog. 

 Then, finally, click OK to create the revised XLS file for use in PontiEC4 

Import revised forces and moments into PontEC4 

 In PontiEC4, with the current data still loaded, select the File> Import 

forces/moments menu item and load the file Forces_and_moments_rev1.xls that 

was created by LUSAS from the working project folder. 

Assess the revised results in PontiEC4 

 Select the Window> Summary of results menu item. 

 Sort the SigEd/fy column. It can be seen that values of SigEd/fy have changed 

slightly from the values previously calculated in PontiEC4 that used the initial 

forces and moments calculated by LUSAS, but values for all segments can be seen 

to pass the check for normal stresses at ULS. 

 

Methods for graphing data and producing detailed results will now be explained. 

Creating Graphs 

 In PontiEC4, with the optimized data still loaded, select the Utilities> Graphs 

menu item. (If the optimized data is no longer loaded open the file 

Composite_Bridge_Deck_Optimized.csv to populate the dialogs) 
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 From the first drop-down list choose ULS: Absolute utilization ratio Eta to plot 

the following graph: 

 

 From the first drop-down list choose ULS: Shear utilization ratio Eta3  to plot the 

following graph: 

 

Note. Graphs can also be viewed by scrolling the mouse wheel up and down in the 

graph window. 
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Obtaining more detailed results 

 With the optimized data still loaded, select the Window> Results menu item.  

 In the Cross-sections and design combinations panel, select section E_30_11 and 

Fund. ULS, Mmin.  

 Select the Stresses tab to have a look at the elastic stresses on the gross section. 

 Then, select the Plastic check tab. From this, all details about the classification and 

plastic check are supplied, and it can be seen that for Stage 3, this section, that is 

part of the segment in the middle of the span, is in Class 1. 

 

Note. At the bottom-left of the Plastic check page the section classification is also 

provided for Phase 1, where the top (upper) flange cannot be considered to be 

restrained by the slab. For this case, the section is in Class 4 as highlighted in the red 

message. For this situation a check of stresses in Phase 1 should be performed, using an 

effective section rather than a gross section.  

To check stresses on the effective section in Phase1 

 Select the Window> Geometry menu item. 

 On the Geometry dialog, double-click on Segment E in the segment treeview to 

change from Edit mode to Input mode. The status bar should state: “Input 

GEOMETRY” 

 In the Segment name field in the top-left of the dialog page (and not in the segment 

treeview panel) change the segment name from E to E_Phase1, then click outside 

of the text box to be sure that the new name is saved. 

 Right-click inside the Sections text box and select Data grid input 
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 Select all rows except for the one with 30_11 in it (use the Ctrl key for a multiple 

selection of rows), open the context menu with the right-hand click of the mouse, 

and select Remove rows to leave just 30_11 remaining. Click OK. 

 In the Structural steel panel uncheck  the option Top Flange in Class 1 

 In the Slab concrete panel input 0 in each of the bcls, b1 and bsx text boxes  

 Click the Add to list button beneath the Segment 

treeview to add the new segment to the list of other 

segments in the segment treeview, as shown right. 

 Select the Window> Forces and moments menu 

item, and on the Results dialog, select ULS fund., 

Mmin in the dropdown list seen in the Cross-

sections and design combinations panel in the top-

left corner. 

 Copy the four cells of forces and moment data for Phase 1 from section E_30_11, 

(click No to not copy the header text) and paste the copied data into the equivalent 

cells for section E_Phase1_30_11, as shown on the following images.  

 

 

 Select the Window> Results menu item 

 Select Section E_Phase1_30_11 and Fund. ULS, Mmin from the Cross-sections 

and design combinations panel. 

 Select the Plastic check tab to see a coherent classification with an only steel 

structural section 
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 Lastly, select the Stresses tab to see the stresses calculated on an effective cross 

section 

 

 

This completes the example. 
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