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Where do | start?

Start by reading this introduction in its entirety. It contains useful general information
about the LUSAS Modeller user interface and details of how the examples are
formatted.

Software requirements

The LUSAS software version, software product (and version of that product) and any
product options that are required in order to run an example will be stated in a usage
box at the beginning of each worked example, like this:

For LUSAS version: 16.0

For software product(s): | All (except LT versions)

With product option(s): Nonlinear

The example exceeds the limits of the LUSAS Teaching and Training Version

Note that Composite examples can be run in any software product if a Composite
product option has been purchased. Similarly, LUSAS Analyst or LUSAS Composite
products can run bridge or civil examples if a Bridge or Civil product option was
purchased. The LUSAS Academic software product will run any example provided the
correct product option is selected during start-up.
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What software do | have installed?

To find out which software product(s), which version of that product, and which
software options are installed and licensed for your use run LUSAS and select Help >
About LUSAS Modeller and press the Key Information button to display a dialog
that lists the facilities and options supported by your software license.

About the examples

The examples are of varying complexity and cover different modelling and analysis
procedures using LUSAS. The first example in this manual contains detailed
information to guide you through the procedures involved in building a LUSAS model,
running an analysis and viewing the results. This fully worked example details the
contents of each dialog used and the necessary text entry and mouse clicks involved.
The remaining examples assume that you have completed the fully worked example and
may not necessarily contain the same level of information. It will benefit you to work
through as many examples as possible, even if they have no direct bearing on your
immediate analysis interests.

Except where mentioned, all examples are written to allow modelling and analysis to be
carried out with the Teaching and Training version of LUSAS which has restrictions on
problem size. The teaching and training version limits are currently set as follows:

500 100 250 1500 10
Nodes Points Elements Degrees of Freedom Loadcases

Because of the modelling and analysis limits imposed by the Teaching and Training
Versions some examples may contain coarse mesh arrangements that do not necessarily
constitute good modelling practice. In these situations these examples should only be
used to illustrate the LUSAS modelling methods and analysis procedures involved and
should not necessarily be used as examples of how to analyse a particular type of
structure in detail.

Format of the examples
Headings
Each example contains some or all of the following main headings:

U Description contains a summary of the example, defining geometry, material
properties, analysis requirements and results processing requirements.

¢ Objectives states the aims of the analysis.




| Geometry
| Point >
Coordinates...

Format of the examples

o Keywords contains a list of keywords as an aid to selecting the correct
examples to run.

o Associated Files contains a list of files held in the \<Lusas
Installation Folder>\Examples\Modeller directory that are associated with
the example. These files are used to re-build models if you have problems, or
can be used to quickly build a model to skip to a certain part of an example,
for instance, if you are only interested in the results processing stage.

O Modelling contains procedures for defining the features and attribute datasets
to prepare the LUSAS model file. Multiple model files are created in some of
the more complex examples and these therefore contain more than one
‘Modelling’ section.

U0 Running the Analysis contains details for running the analysis and
assistance should the analysis fails for any reason.

0 Viewing the Results contains procedures for results processing using
various methods.

Menu commands

Menu entries to be selected are shown as follows:

This implies that the Geometry menu should be selected from the menu bar, followed
by Point, followed by the Coordinates... option.

Sometimes when a menu entry is referred to in the body text of an example it is written
using a bold text style. For example the menu entry shown above would be written as
Geometry > Point > Coordinates...

Toolbar buttons

For certain commands a toolbar button will also be shown to show the ‘short-cut’
option to the same command that could be used instead:

{jl The toolbar button for the Geometry > Point > Coordinates... command is
shown here.

User actions

Actions that you need to carry out are generally bulleted (the exception is when they are
immediately to the right of a menu command or a toolbar button) and any text that has
to be entered is written in a bold text style as follows:

e Enter coordinates of (10, 20).




| Geometry
| Point >
| Coordinates...

| File
[New...

| File

| Script >
| Run Script...
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So the selection of a typical menu command (or the equivalent toolbar button) and the
subsequent action to be carried out would appear as follows:

El Enter coordinates of (10, 20).

Selecting the menu commands, or the toolbar button shown will cause a dialog box to
be displayed in which the coordinates 10, 20 should be entered.

Filling-in dialogs

For filling-in dialogs a bold text style is used to indicate the text that must be entered.
Items to be selected from drop-down lists or radio buttons that need to be picked also
use a bold text style. For example:

e In the New Model dialog enter the filename as frame_2d and click the OK
button to finish.

Grey-boxed text

Grey-boxed text indicates a procedure that only needs to be performed if problems
occur with the modelling or analysis of the example. An example follows:

Rebuilding a model

Ql Start a new model file. If an existing model is open Modeller will prompt for any
un-saved data to be saved before opening the new file.

e Enter the file name as example

To recreate the model, select the file example_modelling.vbs located in the \<LUSAS
Installation Folder>\Examples\Modeller directory.

Associated Files / Visual Basic Scripts

Each example may reference associated files that should be loaded or run during the
course of an example. Thease include files such as model files, spreadsheets, data files
as well as Visual Basic script files. These files are supplied on the release kit are
installed into the \<Lusas Installation Folder>\Examples\Modeller directory.

Updates to these files may occasionally be made between software releases, and if done
revised files will be made available for download from the User Area of the LUSAS
website.
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Model files

Depending upon your access rights it may be necessary to copy a supplied model file to
another folder before it can be opened, and remove the read-only protection before it
can be saved (by Modeller) to a new folder with the same name.

VBS Files

If results processing and not the actual modelling of an example is only of interest to
you the VBS files provided will allow you to quickly build a model for analysis. These
scripts are also for use when it proves impossible for you to correct any errors made
prior to running an analysis of an example. They allow you to re-create a model from
scratch and run an analysis successfully. For more details refer to 'Creating a Model
From The Supplied VBS files'.

Modelling Units

At the beginning of each example the modelling units used will be stated something like
this:

“Units used are N, m, kg, s, C throughout”

Model units are specified as part of the creation of a new model and are reported at all
times in the status bar at the bottom of the Modeller window. Once set, for all dialogs
with grid cells permitting dimensional input, the units expected are displayed as a
tooltip when the cursor is hovered over the input cell.

Timescale Units

Timescale units are specified as part of the creation of a new model and can be changed
on the Model Properties dialog. Choosing a timescale unit dictates how time-based
values are displayed on dialogs during modelling, and how they are output when
processing results

lcons Used

Throughout the examples, files, notes, tips and warnings icons may be found. They can
be seen in the left margin.

Files. The diskette icon is used to indicate files used or created in an example.

Note. A note is information relevant to the current topic that should be drawn to your
attention. Notes may cover useful additional information or bring out points requiring
additional care in their execution.
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Tip. Atip is a useful point or technique that will help to make the software easier to
& ey

Caution. A caution is used to alert you to something that could cause an inadvertent
4 s error to be made, or a potential corruption of data, or perhaps give you results that you
would not otherwise expect. Cautions are rare, so take heed if they appear in the
example.

Running LUSAS Modeller

e Start LUSAS Modeller from the start programs menu. This differs according to the
operating system in use, but typically is done by selecting:

‘Start’ > All Programs > LUSAS 16.0 > LUSAS Modeller
e Alicence option will need to be selected in order to allow access to the software.

e The on-line help system will be displayed showing the latest changes to the
software.

e Close the on-line Help system window.

(LUSAS Academic version only)

e Select a LUSAS product appropriate for the rYs——T—
worked example that is to be carried out, and

click the OK button. Academic Version
Mot for Commercial Use

Select Product

& LUSAS snalyst
0 LUSAS Composite
€ LUSAS Civil & Structural

¢ LUSAS Bridge

ok |




Creating a new model / opening an existing

model

When running LUSAS for
the first time the LUSAS
Modeller Startup dialog will
be displayed. This dialog
allows either a new model to
be created, or an existing
model to be opened.

Note. When an existing
model is loaded a check is
made by LUSAS to see if a
results file of the same name
exists. If so, you have the
option to load the results file
on top of the opened model.

Note.

LUSAS Modeller Startup

* Create new model

% " Open existing file

More Files...
1 D:ALUSAST 445 Neegmental_brdge_Edive.mdl
2 DeALUSAST 445 Sseamental_bridge_correct. mdl
3 DeALUSAST 445Projectsh. . hzegmental_bridge. mdl
4 multiple_tapering_sections_full_azsignment.md

o]

Results

Cahcel

If an existing model is loaded, that in a previous session caused a crash to

occur in LUSAS Modeller, options are provided to help you to recover your model

data.

If creating a new model the
New Model dialog will be
displayed.

e Enter information
and make selections
for the new model
and click the OK

button.
Product  specific  menu
entries for the selected

software product in use e.g.
Bridge or Civil or Design
will be added to the LUSAS
Modeller menu bar.

New Model

File name I

—Warking Folder

' Recent IC:'(modaIs

& User-defined IC:\Usersl,pau\_b\,Documantsl,LUSnS 16.04Projects Set...
[ Model properties

Analysis type ITharmaI x| Madel units INJkauJSJC 'l

Analysis category |<Se\ect> j Timescale units ISeconds ‘l
—Optional

Startup template INone 'l | Layout grid INUI‘IE 'l

Title |

Job number I

OF I Cancel Help
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Saving model files

The worked examples as written do not generally advise you where to save a model,
and by default the New Model dialog will initially save files to the <LUSAS Installation
Folder>\Projects directory. For the purposes of carrying out the various examples of
interest this is acceptable, but note that for real ‘live’ projects it may be beneficial to
save models in separate project folders, each named according to the individual project
that will be undertaken. This can assist with backup and eventual deletion of data on a
project-by-project basis.

Specifying the saved location of results/intermediate files

The LUSAS Configuration Utility can be used to specify where files created in the
course of building a model are saved. See the online help pages for details of how to
access this tool. Using this facility, the location of files that are created in the course of
a building a model and running the various analyses associated with it can be specified
as bheing:

O Within a folder for each model, within a folder called " Associated Model
Data" This is the default setting. Note that the model file itself does not reside
within the folder created.

Q Within a folder with the same name as the model Note that the model file
itself does not reside within the folder created.

O Within the same folder as the model (This was the Version 14.7 behaviour)

U To a specified folder where the location can be defined by internal LUSAS
tokens and ordinary text. For example, the token%ModelLocn% is substituted
with the working current folder for the model; and %6ModelName%o is
substituted with the model's file name. Relative links (e.g. ..\ to use the parent
folder) can alternatively be specified.

For the purposes of carrying out the worked examples these settings do not need to be
changed.

Creating a Model from the Supplied VBS Files

If results processing and not the actual modelling of an example is only of interest, the
VBS files provided will allow you to quickly build a model for analysis.

Proceed as follows to create the model from the relevant VVBS file supplied:

| File

New... Ql Start a new model file.

e Enter the file name as example name and click OK




| File
[ Script >
Run Script...

The LUSAS Modeller Interface

&l Select the file example_name_modelling.vbs located in the \<LUSAS
Installation Folder>\Examples\Modeller directory, or if you have downloaded, saved
and unzipped any associated files for the LUSAS examples from the User Area of the
LUSAS website, locate the relevant file on your system and open that instead.

Note. VBS scripts that create models automatically perform a File > Save menu
command as the end.

Some additional modelling may need to be carried out prior to an analysis being run.
See individual examples for details.

The LUSAS Modeller Interface

The principal regions and components of theModeller user interface are shown on the
following image and are described in the following pages.

& Ey
B rie ot View Geomety st

steel_design Eurocode\stsel_desi

& Text Output Window Selected / Cyclable Items

ggered fxo
b =
e

Status bar

Main Menu and Toolbars

The main menu and associated toolbars which contain toolbar buttons provide the
means to define model related geometry and other data. On initial start-up of

LUSAS Modeller the Main, Define and View Toolbars are displayed. All toolbars can
be shown, hidden, or customised, using the View> Toolbars menu item.

Modelling in LUSAS

A LUSAS model is graphically represented by geometry features (points, lines,
surfaces, volumes) which are assigned attributes (mesh, geometric, material, support,
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loading etc.). Geometry is defined using a whole range of tools under the Geometry
menu, or the buttons on the Toolbars. Attributes are defined from the Attributes menu.
Once defined attributes are listed in their respective Treeviews, prior to being assigned
to selected parts of a model.

View Window

a

A View Window shows the model according to user-defined settings made
else where on the user interface. Any number of view windows can be defined.
Each view window is completely independent and may show the model from a
different angle, using different visualization options, with or without results.
The image in a view window is built up from several drawing layers as listed
in the Layers Treeview (see Main Panels below). Each layer draws over the
top of the one before it.

A Datatip provides model-related information about whatever is under the
cursor. .

Main Panels / Treeviews

Each of the main panels has its own Treeview showing a list of objects of a particular
type. Treeviews are used to organise various aspects of the model in graphical frames.

There are a number of Treeviews showing Groups , Attributes c&: Analyses @
Utilities -sf’r’ and Reports 2.

Q

a

The Layers [= Treeview controls the display of selective model data and
results data to a view window.

The Groups L=l Treeview is used to store selected user-defined collections of
objects (geometry, nodes or elements) under a collective name.

The Attributes &b Treeview is where defined contains information relating to
the model; the element type and discretisation on the geometry; section
properties and thicknesses; the materials used; how the model is supported or
restrained; and how the model is loaded.

The Analyses (X Treeview shows all analyses defined; loadcases defined
including analysis control loadcases defined during the modelling stage;
results loadcases containing solutions for results processing; loadcase
combinations and envelopes; and IMD and Fatigue calculations.

The Utilities &7~ Treeview contains utility items used in the definition of
model geometry or attributes, or to control an analysis, or to provide a
particular functionality, such as to define a load combination or produce a
report for example.

10
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O The Reports = Treeview contains a user-defined folder structure of reports,
chapter and image entries to allow a report to be generated in a variety of
formats.

Treeviews use drag and drop functionality. For example, an attribute in the Attributes

&b Treeview can be assigned to model geometry by dragging the attribute onto an
object (or objects) currently selected in the graphics window, or by copying and pasting
an attribute onto another valid Treeview item as for instance, a group name, as held in

the Groups L2l Treeview.

Context Menus

Although commands can be accessed from the main menu, pressing the right-hand
mouse button with an object selected usually displays a context menu which provides
access to relevant operations. Treeview panels also have a context menu which provides
access to additional functionality such as editing of data, control of visibility,
visualisation of assignments, and selective control of results plotting on selected
attributes.

Text Output Window

The Text Output Window displays messages and warnings during a modelling session.
When an error message or warning relating to a particular object is written to the text
output window, extra information is usually available by double-clicking on that line of
text.

Selection Panels

O Selection This window is not displayed by default but can be viewed using the
View> Selection Panels > Selection menu item. Once visible it will contain a
list of all currently selected items which may then be individually deselected.

O Cyclable This window is not displayed by default but can be viewed using the
View> Selection Panels > Cyclable Items menu item. Once visible it will
contain a list of all cyclable items. These may then be individually selected or
deselected.

O Selection memory This window is not displayed by default (and is not shown
on the image above) but can be viewed using the View> Selection Panels >
Memory Selection menu item. Once visible it will contain a list of all items
currently in Selection Memory which may then be individually deselected.

Q Visible Items This window is not displayed by default (and is not or shown on
the image above) but can be viewed using the View> Selection Panels >
Visible menu item. Once visible it will contain a list of all items in the active
view, which may then be individually selected / deselected.

11
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The selection panels can be dragged and dropped to any location on screen, docked
with other panels and set to Auto Hide, becoming visible again when the cursor is
positioned over their tab identifier. Double-clicking a docked window will isolate it
again.

Status Bar

The Status Bar displays progress messages and help text during a modelling session, the
model units, the current cursor position in model units (if the model is displayed in an
orthogonal plane) and the item or number of items in the current selection. A view of
the model can be obtained by pressing one of the primary axes shown in the status bar.
The View> Status Bar menu item may be used to hide or show the Status Bar.

Tool Tips

Tool tips (not shown on the image above) provide basic information about whatever is
under the cursor, such as uses of toolbar buttons or expected input for grid cells etc.

Properties

General information relating to a model is presented in property dialogs. Properties may
relate to the whole model or the current window, or a single geometric feature - in fact
most objects have properties. To view an object’s properties, select it, press the right
mouse button, then choose Properties from the context menu

Getting Help
LUSAS contains a comprehensive Help system. The Help consists of the following:

e Most dialogs include a Help button which provides information on that dialog.

e Selecting Help > Help Topics from the main menu provides access to all the Help
files.

2hoW | 1f the Help Contents, the Help Index and the Search facility are not shown

when a help page is first displayed pressing the Show button will show these tabs in the
HTML Help Window.

12



	Introduction to LUSAS Worked Examples
	Where do I start?
	Software requirements
	What software do I have installed?
	About the examples
	Format of the examples
	Headings
	Menu commands
	Toolbar buttons
	User actions
	Filling-in dialogs
	Grey-boxed text
	Rebuilding a model
	Associated Files / Visual Basic Scripts
	Model files
	VBS Files

	Modelling Units
	Timescale Units
	Icons Used

	Running LUSAS Modeller
	(LUSAS Academic version only)

	Creating a new model / opening an existing model
	Saving model files
	Specifying the saved location of results/intermediate files
	Creating a Model from the Supplied VBS Files
	The LUSAS Modeller Interface
	Main Menu and Toolbars
	Modelling in LUSAS
	View Window
	Main Panels / Treeviews
	Context Menus
	Text Output Window
	Selection Panels
	Status Bar
	Tool Tips
	Properties
	Getting Help



