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Composite Highway 

Bridge Design    

In accordance with the Eurocode 

and the UK National Annex 

 

For LUSAS version: 19.0 

For software product(s):  LUSAS Bridge or LUSAS Bridge plus 

With product option(s): Steel and Composite Deck Designer (PontiEC4 – V3.2.7) 

Vehicle Load Optimisation  

With additional software Microsoft Excel installed 

Description 

The global analysis and design of a simple two span continuous bridge is to be carried 

out using the Steel and Composite Deck Designer (PontiEC4) and LUSAS Bridge. 

The primary aim of this particular example is to show the LUSAS model building 

requirements to allow a design check with PontiEC4 to be carried out. A separate 

example ‘Assessment of a Composite Bridge Deck to Eurocodes’ shows the use of the 

PontiEC4 Composite Deck Designer and the interaction between it and a supplied 

LUSAS model. 

The bridge carries a 2-lane highway over another road.  
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A four-girder arrangement has been chosen, and a deck slab thickness of 250 mm has 

been assumed. The girders are spliced at a distance of 6.3m either side of the central 

pier, giving overall girder lengths of 21.7, 12.6 and 21.7m respectively. 

 

Table of main girder properties 

 21.7 m span girder 12.6 m pier girder 21.7 m span girder 

Top flange 500 x 25 500 x 40 500 x 25 

Web 12 18 12 

Bottom flange 500 x 50 650 x 60 500 x 50 

Top rebars B16 @ 150mm  B25 @ 150mm B16 @ 150mm 

Bottom rebars B16 @ 150mm B25 @ 150mm B16 @ 150mm 

 

Bracing arrangement 

7.0 7.0 8.1 5.9 5.9 8.1 7.0 7.0

Splice 0.4 away from bracing

 



Structural Idealisation 

 3 

Objectives 

This shows how the Steel and Composite Deck Designer (PontiEC4) and LUSAS 

Bridge can be used to carry out the analysis and design of the bridge shown previously. 

Keywords 

Steel, Composite, Deck, Designer, Vehicle Load Optimisation, PontiEC4, Design, 

Checking, Import, Export, ULS, SLS, Detailed design. 

Associated files 

 LUSAS_Comp_Bridge.csv - Contains initial material and geometric data 

/ definitions for use with PontiEC4 

 Sections_Rev0.vbs - A file created by PontiEC4 containing geometric 

section data to import into LUSAS. A supplied file is only for use in case of 

difficulties in manually creating the appropriate data. 

 LUSAS_Shrinkage.vbs - A file created by PontiEC4. A supplied file is 

only for use in case of difficulties in manually creating the appropriate data. 

 LUSAS_Thermal.vbs - A file created by PontiEC4. A supplied file is only 

for use in case of difficulties in manually creating the appropriate data. 

 LUSAS_Comp_Bridge.mdl – Model file created by a user. A supplied 

LUSAS model file is only for use in case of difficulties in manually creating the 

appropriate model.  

 Forces_and_moments.xls – File created by the LUSAS Export Forces 

and Moments dialog containing data to import into PontiEC4. A supplied file is 

only for use in case of difficulties in manually creating the appropriate data. 

 Export_Forces_to_PontiEC4.inp - File containing dialog selections 

made on the Export Forces and Moments dialog. 

 LUSAS_Comp_Bridge_Results.csv – Contains revised geometric 

data / definitions for use with PontiEC4 

 Forces_and_moments_optimised.xls  File created from a modified 

LUSAS analysis model (not supplied) containing data to import into PontiEC4. 

Structural Idealisation 

Note. It is understood that the bridge should have different section properties for the 

internal girders and the external girders due the differences in widths of slab associated 

with each girder. This is due to the cantilever being shorter but thicker than half the 

width of slab between girders. So, in reality, the analysis should have different section 




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properties for both the internal and external girders. However for training purposes the 

section properties will be based on the cross section shown below. This is a gross 

simplification but has been done to keep the data creation simple for this example. 

 

For the purposes of this example, only two locations will be considered for detailed 

design. In reality many locations would need to be considered to cover the full design 

of the bridge, but for training purposes this simplification will be accepted.  

Design checks will be carried out: 

 Along girder 2 (the first internal girder), towards the middle of span 1 

 Over the pier support.  

Part 1: Enter section and material data in Steel and 

Composite Deck Designer (PontiEC4) 

Running Steel and Composite Deck Designer (PontiEC4) 

 Run the Steel and Composite Deck Designer (PontiEC4)  

 Select the File> New menu item to create a new project. 

 Select the File> Save as menu item to save the Steel and Composite Deck Designer 

(PontiEC4) dialog data to a working project folder different from the installation 

folder (this would normally be a project folder in which a LUSAS model will also 

be created), with the name LUSAS_Comp_Bridge.csv  

Note. All data entered in the Steel and Composite Deck Designer (PontiEC4) dialogs 

will be saved to this file. Previously created and saved data can be loaded into the Steel 

and Composite Deck Designer (PontiEC4) dialogs by using the File> Open menu item. 

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If this example is undertaken over several sessions ensure that the entered data is saved 

before exiting so that the example can be picked up from where it was left. 

Having started the Steel and Composite Deck Designer (PontiEC4) a number of blank 

dialogs forms will be presented cascading across the screen as shown below. Through 

the design process each of these dialogs will be populated with data, starting with the 

Material dialog. 

 

Note. Under the Windows menu a list of all the dialog names are presented.  Clicking 

a dialog name in the list will bring that dialog to the front of the screen. This allows for 

easy navigation around the various dialogs. 

In the Steel and Composite Deck Designer (PontiEC4) the units in use are always 

indicated in the input and output dialogs, and in general forces are expressed in N 

(Newton), lengths in mm (millimetres) or m (metres), and moments expressed in Nm 

(Newton metres). The units used for the LUSAS model will therefore be N, m, kg, s, C. 


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Defining material properties 

The material dialog is immediately available when you start a new project or when you 

open an existing one. The material dialog is organized into separate panels; Concrete, 

Concrete age, Steel etc.  

 For each panel on the dialog enter the material data as shown in the following 

images. 

Concrete Material Properties 
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Note. The Steel and Composite Deck Designer (PontiEC4) help system contains 

commentary relating to the information being entered including references to the 

Eurocode in question. 

Steel Material Properties 

With the Materials dialog still selected, set the following data for the steel properties: 


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 Click on the Question mark button  next to the Grade field, to define a Steel 

grade of EN 10025-2 S355. 

Fatigue 

 

For the fatigue factors:- 

 2 can be calculated with data input in the window dialog that appears when you 

click on the Question mark button   next to the v,2 input field. Select Traffic 
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category 2 and the heavy vehicle distribution to Medium distance and select OK to 

return to the main dialog.  

 3 can be calculated with data input in the window dialog that appears when you 

click on the Question mark button   next to the v,3 input field. Set the design life 

of the bridge as 100 years and select OK to return to the main dialog.  

 Enter the other factors as shown on the dialog above.  

Save the data entered 

 Select the File> Save menu item to save the PontiEC4 dialog data to the current 

working project folder. 

Defining Geometric properties 

Prior to defining the geometric section properties for the spans, the span lengths and the 

effective concrete slab width (beff) of each section, defined at various distances along 

the section, need to be stated. 

Defining shear lag slab and flanges 

 To input data for the effective slab width calculation, select the Utilities> Shear lag 

slab and flanges menu item. 

 Input an array of the bridge spans (the span lengths) in the text box in the top right 

corner: 28.0, 28.0 and click on the  button. The X distance where the effective 

slab width changes will be automatically set up in the table. 

 For each row input the flange widths b1*, b2*, b0 as 1850, 1850, 400 respectively. 

Note. Values in the table can be selected and copied and pasted into other cells by 

using the context menu. 

 In the Type column ensure that the code 0 is used for the first and last section, 1 for 

the sagging regions, and 2 for the hogging regions over supports. 

 Click the Calculate button to calculate beff 


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 Click the Exit button to close the dialog and return to the material dialog 

 Note. Values of effective length Le are used to calculate the effective width due to 

shear lag effects in the slab and the steel flanges. Also once calculated, the numbers 

are shown with a comma as the thousand separator, so that 1850 becomes 1,850. 

Defining geometric data for the bridge 

The geometric data for sections along the bridge now needs to be defined. Note at this 

stage it is not necessary to define all the sections in each segment that will be checked; 

it will be enough to define just one section for each segment, and input a distance to 

automatically obtain the corresponding effective width of slab from the shear lag slab 

table previously defined. 

To establish the initial section locations some thought needs to be given to the analysis 

model that will be used. 

Analysis model concept layout  

The bridge is to be analysed using the planar grillage analogy with thick beam elements. 

Although grillage analysis is not the most rigorous analysis type, and is unlikely to 

model the effects of bracing correctly, the ability to obtain simple results from beam 

elements with composite sections (transformed section properties), means that it is still 

widely used for bridge analysis. 

The basic girder layout is shown below including splice and bracing locations. 


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7.0 7.0 8.1 5.9 5.9 8.1 7.0 7.0

Splice 0.4 away from bracing

 

As per EN1004-2 clause 5.4.2.3 (3), the region over the internal supports, cracked 

section properties will be assumed to exist for a length equal to 15% of each span, 

either side of the central supports.   

Following the basic rules for setting up a grillage analysis, the layout shown below is 

going to be considered. The virtual grid is formed from lines that follow the original 

girder and bracing locations (shown in black in the following image), and lines 

representing the additional transverse members (shown in grey) to ensure a similar 

longitudinal and traverse member spacing. Points will also need to be added at the 

splice locations and at the start of the cracked section properties.  
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So, for the basic geometric sections in the grillage, only four sections will be used: Span 

Girder A, Span Girder B and Pier Girder (cracked and uncracked) as shown on the 

following image: 

 

Defining geometric data for Span Girder A 

The geometric data for each segment and/or section along the bridge now needs to be 

defined, starting with Span Girder A. 

Note. A girder may be formed / analysed from any number of Segments (a length of 

girder over which all parameters - apart from the total height of steel section and the 

attributed concrete slab width -remain constant) that are labelled such as Span Girder A, 

Span Girder B, etc. Sections are locations defined within a segment at which geometric 

properties are defined or calculated. Both terms are used throughout this example. 

Segment name, sections, X-distances 

 From the main menu select Windows> 2 Geometry to display the Geometry dialog. 

 In the Segment name panel enter the following: 

 

Steel section sizes 

In the Structural steel panel enter the following: 


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 Make sure that Top flange in Class 1 (no local buckling because attached to the 

concrete slab) is checked (ticked) 

 Make sure that Top Flange≤40mm is checked (ticked) 

Note. The checkboxes for Top / Bottom flange ≤ 40mm are only required to be 

checked if the flanges have total thickness greater than 40mm but are formed from 

multiple plates each of a thickness less than 40mm. When checked (ticked), ultimate 

and yielding tension for steel less than or equal to 40mm thickness will be used. 

Vertical web stiffener distance 

 In the Vertical stiffeners panel enter the following: 

 

Note.. A vertical stiffeners check is optional and is not carried out in the example. 

Specifying the distance between vertical stiffeners is the only mandatory value in this 

panel. 

Slab concrete 

 In the Slab concrete panel, right-click inside the bcls field and select Calculate 

beff. The width of slab will be computed using data previously defined in the shear 

lag table. Input other data as shown in the following image. 

 




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For this example, the section properties of the concrete haunch will be ignored in any 

calculations that are made, so it is left un-checked. 

Reinforcing bars 

 In the reinforcing bars panel enter the following: 

 

Shear connection 

 In the Shear connection panel enter the following: 

 

Note. The values for ‘Distance elastic-plastic section for ULS-min’ and ‘Resulting 

compression in the concrete slab, at L from current section for ULS M-min’ cannot be 

determined this early in the design process and are therefore defined as zero for now. 

These values must be revisited after the bridge has been analysed and design 

calculations performed. 

Fatigue data 

 In the Fatigue panel enter the following: 

 

 1 can be calculated automatically by clicking the Question mark button  next to 

the input field and then, on the Damage equivalent factor dialog, selecting the radio 

button for the midspan section and entering 28.0 for the Span length for moments 

and 11.2 for the Span length for shears 


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Detail categories 

 In the Fatigue data panel, select the Detail categories data button and define the 

following data: 
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No value is required for Horizontal stiffener-Web 

Adding data for Span Girder A to the segment treeview 

 Click on the Add to list button located under the segment treeview to save all the 

data entered for Span Girder A. 

 Before entering data for other segments, in the segment treeview double-click on 

the name of the Span Girder A. All data previously input for the previous section is 

now available for use in defining the next section. 

Note. Double-clicking on a segment name in the Segment treeview panel will 

switch PontiEC4 from EDIT MODE to INPUT MODE. The status bar at the 

bottom-left of the screen will always show what mode is being used at any time. 

Defining geometry for Span Girder B 

With the status bar stating ‘INPUT GEOMETRY:’ 

 In the Segment name field delete Span Girder A and type Span Girder B.  

 Change the Section name to Middle and Distance X to be 14 

 In the Vertical stiffeners panel, set the distance between stiffeners to 8100  

 In the Slab concrete panel, re-calculate the values of bcls and bsx by selecting 

Calculate beff from the context menu for the bcls cell. 


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 Click on the Add to list button located under the segment treeview to save all the 

data entered for Span Girder B. 

 Before entering data for other segments, in the segment treeview double-click on 

the name of the Span Girder A. All data previously input for this section is now 

available for use in defining the next section. 

Defining geometric data for the Pier Girder 

 In the Segment name field delete Span Girder A and type Pier Girder.  

 Change the Section name to Pier and the Distance X to be 28 

 In the Structural steel panel, change the top flange thickness ts to 40 

 Change the Web thickness twr to 18 

 Change the Bottom flange width bi to 650 and thickness ti to 60 

 In the Vertical stiffeners panel, set the distance between stiffeners to be 8100  

 In the Slab concrete panel, re-calculate the values of bcls and bsx. Remember that 

the values of bcls and bsx can be calculated automatically by selecting Calculate 

beff from the context menu for both fields. 

 In the Reinforcing bars panel, set the top layer reinforcement bar diameter to 25 

and bottom layer reinforcement bar diameter to 25 
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 In the Fatigue panel, 1 can be calculated automatically by clicking the Question 

mark button  next to the input field and then, on the Damage equivalent factor 

dialog, select the radio button for the support section and enter 28 for the Span 

length for moments and 28 for the Span length for shears 

 

 Click on the Add to list button located under the segment treeview to save all the 

data entered for the Pier Girder. 

Save the entered data 

 Select the File> Save menu item to save the PontiEC4 dialog data to the current 

working project folder. 
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Part 2: Export properties from Steel and Composite Deck 

Designer PontiEC4 to LUSAS Bridge 

Associated Files 

These supplied files are only for use in case of problems in manually creating the 

appropriate data in this section of the example. 

 LUSAS_Comp_Bridge.csv - the input file for PontiEC4 with data on 

sections and materials. 

 

Prior to exporting geometric properties, the Steel and Composite Deck Designer 

(PontiEC4) needs to check that all the data that has been input is valid, and then run 

part of the EC4 code check to calculate the required geometric properties of each 

defined cross section. This is automatically done when requesting to view the Results 

window/dialog and should always be done prior to exporting properties subsequently. 

 On the main Steel and Composite Deck Designer (PontiEC4) menu select 

Window> 4 Results to set the Results dialog active. After a short delay whilst a 

partial code check is run, the geometric properties of each cross section will be 

calculated. This can be confirmed by selecting a Cross-section and Design 

combination with the Geometric properties 2 tab active. 

 When complete, select File> Export geometric properties to LUSAS 

 On the dialog, browse to your working 

project folder and enter a filename of 

“LUSAS_Sections_Rev0.vbs”.  

 Select (check) all the Export check boxes 

(apart from Export Phase 2c). 

 Ensure that the option ‘Distance middle 

plane of slab – neutral axis’ is not 

selected 

 Ensure that the option Assume slab width 

constant and use minimum value is selected. Click OK to finish. 

Phases explained 

 Phase 1 – Steel sections only, non-composite action.  Slab will be considered 

only as load. 


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 Phase 2a - The composite sections with long term properties of the concrete.  

Loadings considered are the permanent ones. 

 Phase 2b - The composite sections with long term properties of the concrete. 

Loading considered is the shrinkage of the concrete. 

 Phase 2c – this represents the actions arising from prestressing and is therefore 

not required in this example. 

 Phase 3 - The composite sections with short term properties of the concrete.  

Loading considered are the variable actions. 

Next, the equivalent loading for the shrinkage effects can be exported. 

 Select File> Export equivalent DT to LUSAS 

 Browse to the working project folder and enter a filename of 

“LUSAS_Shrinkage.vbs”.  

 Select the Shrinkage option and Click OK to finish. 

Finally, the loading for the temperature effects can be exported. 

 Select File> Export equivalent DT to LUSAS 

 Browse to the working project folder and enter a filename of 

“LUSAS_Thermal.vbs”.  

 Select the Thermal option and Click OK to finish. 

Part 3: Building the LUSAS analysis model 

Running LUSAS Modeller 

For details of how to run LUSAS Modeller, see the heading Running LUSAS Modeller 

in the Examples Manual Introduction. 

Note. This example is written assuming a new LUSAS Modeller session has been 

started. If continuing from an existing Modeller session, select the menu command File 

> New to start a new model file. Modeller will prompt for any unsaved data and display 

the New Model dialog. 

Creating a new model 

 Enter the file name as LUSAS_Comp_Bridge 


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 Set the working folder to be the same as that used for the PontiEC4 dialog data. 

 Enter the title as Composite highway bridge design 

 Select units of N,m,kg,s,C 

Caution.  It is important that the units used in the Steel and Composite Deck 

Designer (PontiEC4) are also specified for LUSAS model.  If consistent units are not 

used, the results obtained will be incorrect. 

 Leave timescale units as Seconds 

 Ensure the Structural analysis type is selected. 

 Set an analysis category of 2D Grillage / Plate 

 Leave the startup template set to None 

 Select the Vertical Z Axis option. 

 Click the OK button. 

Note. Use the Undo button to correct any mistakes made since the last save was done. 

Import of section properties  

The section properties exported from Steel and Composite Deck Designer (PontiEC4) 

need to be imported into LUSAS 

Locate the “LUSAS_Sections_Rev0.vbs” and open in LUSAS.  

 Select the file LUSAS_Sections_Rev0.vbs and click OK. 

This will populate the Attributes  treeview with the geometric section properties and 

material properties exported from Steel and Composite Deck Designer (PontiEC4) as 

shown below. 

Important. In the final stage of this example the Steel and Composite Deck 

Designer (PontiEC4) inspects the segment names in order to extract properties 

from the attributes for the design process.  In order for this to happen the 

attribute name needs to be defined in a recognised format.  For this reason the 

cross-section geometric properties in any associated LUSAS model must have a 

name that follows this standard:  

[Segment Name] +”__”+ [Phase name]; where the phase name should be: {F1, 

F2a, F2b, F3a, F3b, cracked}.  

e.g. Span Girder A__F1 





File 

Script > 

Run Script… 


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The cracked status of the section is a Boolean value taken as true when the phase 

name is “cracked”, and false otherwise. 

Any sections imported from the Steel and Composite Deck Designer (PontiEC4) 

will automatically be defined in the correct format. 

 

 

Now that the geometric and material properties have been imported, the analysis model 

that will use them can be constructed. 

As discussed earlier in this example a simple grillage analogy will be used for the 

analysis model.  The grillage wizard could be used but in this example the grillage will 

be constructed manually based on the layout and dimensions shown below. 
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Defining the base geometry 

 Enter coordinates of (0, 0), and (3.5, 0), to define the first Line of the grillage.  

 Select the Line that has just drawn. 

 Copy the Line through a translation of X= 3.5, Y= 0, Z = 0, set the number of 

copies to 3 and click OK to create further Lines. 

 Select the Point at the right hand end of the Line that is furthest to the right. 

 Sweep the Point through a translation of X= 4.05, Y= 0, Z = 0 and click OK to 

create a Line.  

 Repeat the process of selecting the Point at the right hand end of the Line that is 

furthest to the right and sweeping using the following translations:- 

X= 3.65, Y= 0, Z = 0 

X= 0.4, Y= 0, Z = 0 

X= 1.7, Y= 0, Z = 0 

X= 1.25, Y= 0, Z = 0 

X= 2.95, Y= 0, Z = 0 

X= 2.95, Y= 0, Z = 0 

X= 1.25, Y= 0, Z = 0   

X= 1.7, Y= 0, Z = 0 

X= 0.4, Y= 0, Z = 0 

X= 3.65, Y= 0, Z = 0 

X= 4.05, Y= 0, Z = 0 

X= 3.5, Y= 0, Z = 0 

 Select the line furthest to the right. 

 Copy the Line through a translation of X= 3.5, Y= 0, Z = 0, set the number of 

copies to 3 and click OK to create further Lines. 

Geometry 

Line > 

Coordinates… 

Geometry 

Line > 

Copy… 

Geometry 

Line > 

By Sweeping… 

Geometry 

Line > 

By Sweeping… 

Geometry 

Line > 

Copy… 
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 Select all the Points in the model except the four points that represent the splice 

locations and where the cracked section properties start – as shown by arrows on th 

image that follows. 

Tip.  Select the ‘Select Points’ cursor and use the Shift key to add to each set of 

selections made. 

 

 Sweep the selected Points through a translation of X= 0, Y= 3.7, Z = 0 and click 

OK to create Lines. 

 Ensure the ‘Select Any’ cursor is back in use. 

 Select everything on the screen, all the lines. 

 Copy the Lines through a translation of X= 0, Y= 3.7, Z = 0, set the number of 

copies to 3 and click OK to create further Lines. 

 Select the additional unwanted Lines shown below. 

Tip.  Hold down the Alt key whilst dragging a selection box through the extent of all 

the lines. 

 



Geometry 

Line > 

By Sweeping… 

Geometry 

Line > 

Copy… 


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 Delete the selected Lines, confirming that Lines and Points are to be deleted. 

Defining groups 

Model features will be grouped together to make assignment of attributes and viewing 

of model results easier. Lines representing the different geometric sections will be 

formed into named groups. 

Span girder A 

 Select the eight lines at each end of the deck which will have Span Girder A 

properties assigned to them. 

 

Tip.  Select the ‘Select X axis’ cursor and box-select the lines at each end of the deck. 

Use the Shift key to add to the previous selection made. 

 This adds a New Group entry in the  Treeview for the features selected.  

 

 Enter the group name as Span Girder A and click OK to finish defining the group. 

Span girder B 

 Next, select the thirty-two lines which will have Span Girder B properties assigned 

to them. 

 

 This adds a New Group entry for the features selected.  

 

 Enter the group name as Span Girder B and click OK to finish defining the group.  


Geometry 

Group > 

New Group 

Geometry 

Group > 

New Group 
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Pier girder uncracked region 

 Next, select the sixteen lines which will have Pier Girder Uncracked properties 

assigned to them. These are the lines between the splice and the point where the 

cracked section properties start. 

 

 This adds a New Group entry for the features selected. 

 

 Enter the group name as Pier Girder Uncracked and click OK to finish defining 

the group.  

Pier girder cracked region 

 Select the sixteen lines which will have the Pier Girder Cracked properties 

assigned to them. 

 

 This adds a New Group entry for the features selected.  

 

 Enter the group name as Pier Girder Cracked and click OK to finish defining the 

group. 

Main girders 

 Select all the longitudinal lines. 

Geometry 

Group > 

New Group 

Geometry 

Group > 

New Group 
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 This adds a New Group entry for the features selected.  

 

 Enter the group name as Main Girders and click OK to finish defining the group.  

Transverse slab 

 Select all the transverse lines 

Tip.  Select the ‘Select Y axis’ cursor and box-select the whole model. 

 

 This adds a New Group entry for the features selected.  

 

 Enter the group name as Transverse Slab and click OK to finish defining the 

group.  

 Ensure the ‘Select Any’ cursor is back in use. 

Construction phases 

Note. To carry out the design of the bridge the analysis model will need to have the 

relevant construction phases (Phase 1, Phase 2a, Phase 2b and Phase 3) simulated 

within the analysis model. Normally the order that these would be listed in the Analyses 

treeview for the model would mimic the construction process, so Phase 1 would come 

before Phase 2a.  However it is intended to use the Traffic Load Optimisation facility 

with LUSAS to generate the Traffic load patterns for Phase 3. This will require 

influence analysis to be undertaken and currently when running an influence analysis 

the properties of the base analysis are always considered for the influence analysis.  

Therefore the base analysis will actually be set with the short term properties that are 

Geometry 

Group > 

New Group 
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used for Phase 3.  So the actual order that the Phases will be dealt with in this example 

will be Phase 3 first, followed by Phase 2b, Phase 2a and finally Phase 1. 

Defining and Assigning Mesh Attributes 

 The grillage Lines are to be modelled with 3D Thick Beam, Linear elements 

(BMI21 elements) with 1 mesh division. 

 Enter the attribute name as Thick Beam and click OK. 

 Select all Lines in the model and drag and drop the Thick Beam mesh from the  

Treeview onto the selected features. Click OK to assign. 

Defining Geometric Properties 

The section properties for the longitudinal members in the grillage have been imported 

in LUSAS earlier in this example.  However the transverse section properties for the 

slab sections now need to be created.  

Only a single transverse section will be defined for this example and this will be used in 

all locations. This is a simplification as the grillage bays are of different widths and the 

transverse section should be based on size of grillage bays. 

 Ensure that the usage is set to 3D Thick Beam 

 Enter the Cross sectional area (A) = 0.875, Second moment of area about y axis 

(Iyy) = 0.004653 , Second moment of area about z axis (Izz) = 0.1667  Torsinal 

constant (J) = 0.00911,  Effective shear area in y direction (Asy) = 0.729 and 

Effective shear area in z direction (Asz) = 0.729  

 Enter the attribute name as Transverse Slab and click OK. 

Assigning Geometric Properties 

As an alternative to selecting features by dragging a box around them, the previously 

named Groups will be used. 

 Select the fleshing on/off button to turn-off geometric property visualisation. 

 In the  Treeview, click the right-hand mouse button on the group name Span 

Girder A and select the Select Members option from the menu. If you already 

have some features selected click Yes to deselect them first. 

 From the  Treeview, drag and drop the geometric attribute Span Girder A__F3 

onto the selected Lines. 

Attributes 

Mesh > 

Line… 

Attributes 

Geometric > 

Line… 
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Repeat this operation for the following assignments: 

 In the  Treeview, select the 

members of each group, clicking Yes 

to deselect any existing selection. 

 From the  Treeview, drag and drop 

each named geometric attribute  

onto the selected lines 

 Span Girder B  Span Girder B__F3 

 Pier Girder Uncracked  Pier Girder__F3 

 Pier Girder Cracked  Pier Girder__Cracked 

 Transverse Slab  Transverse slab 

 

Checking Geometric Assignments 

 Double-click on the Geometry layer in the  Treeview and select Assignment 

from the Colour by drop down list. Click the Set button and select Geometric from 

the Attribute Type drop down list. 

 With the Generate key option selected click the OK button to return to the 

Geometry properties dialog and OK again to display the geometry coloured by 

geometric assignment with the key annotated.  

 
 To remove the ‘Colour by Attribute’ assignment double click on Geometry in the 

 Treeview, select Own Colour from the Colour by drop down list and click OK 

to update the display.  
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Defining and Assigning Material Properties 

The materials for the grillage have already been imported into LUSAS earlier in this 

example. These properties now need to be assigned to selected members of the model 

as follows: 

 In the  

Treeview, select 

the members of 

each group, 

clicking Yes to 

deselect any 

existing 

selection. 

 From the  Treeview, 

drag and drop each 

named material 

attribute  onto the 

selected lines 

 Assign to 

Analysis 

 Assign to 

Loadcase 

 Main Girders  Steel  Analysis 1   Loadcase 1 

 Transverse Slab  Concrete_short_term

_Phase3 

 Analysis 1   Loadcase 1 

Defining and Assigning Supports 

Define supports that set up the correct articulation for the structure. In this example the 

bridge will have one pinned support, one guided support and the remainder of the 

supports will be vertical. 

 Click on the option Fixed for the Translation in X, Y and Z.  

 Enter the attribute name as Pinned (X,Y,Z) and click the Apply button to add the 

attribute to the  Treeview and keep the dialog active.  

 Click on the option Free for the Translation in X.  

 Enter the attribute name as Guide (Y,Z) and click the Apply button to add the 

attribute to the  Treeview and keep the dialog active.  

 Click on the option Free for the Translation in Y.  

 Enter the attribute name as Vertical (Z) and click the OK button to add the attribute 

to the  Treeview.  

Assign the supports to the model 

 Box-select the Points that represent each of bearing locations and drag and drop the 

support attribute Vertical (Z) from the  Treeview onto the selection. With the 

Attributes 

Support… 
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Assign to Points option selected click OK to assign the support attribute to 

Analysis 1 for all Analysis loadcases. 

 Select the Point on the left hand side of the grillage on the line representing the 

second girder and drag and drop the support attribute Pinned (X,Y,Z) from the  

Treeview onto the selection. With the Assign to Points option selected click OK to 

assign the support attribute to Analysis 1 for all Analysis loadcases. This will 

replace the previous support assignment. 

 Select the Point on the right hand side of the grillage on the line representing the 

second girder and drag and drop the support attribute Guide (Y,Z) from the  

Treeview onto the selection. With the Assign to Points option selected click OK to 

assign the support attribute to Analysis 1 for all Analysis loadcases. This will 

replace the previous support assignment. 

Note. Only one support can be assigned to a point in one loadcase. 

 

Defining and Assigning Loading 

In the first analysis, variable actions will be considered. Thermal effects are variable 

actions that will be applied to the analysis.  

Note. In this example it is going to be assumed that the simplified approach to the 

thermal loading can be used. However it should be noted that in BS EN 1991-1-5, 

6.1.2(2) it is stated that this simplified approach should only be used if it is agreed for 


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the individual project with the relevant authority.  Otherwise an approach using a 

nonlinear thermal profile should be adopted. 

Earlier in the example the Thermal effects were exported from the Composite Deck 

Designer (PontiEC4) into a file called “LUSAS_Thermal.vbs”. 

Locate the “LUSAS_Thermal.vbs” and open in LUSAS.  

 Select the file LUSAS_Thermal.vbs and press OK to open in LUSAS. 

This adds some thermal load attributes to the Attributes  treeview as shown: 

 

 These attributes are to be renamed. Right-click on each in turn and rename the label 

VarTermica to be Thermal. 

Assigning thermal loading 

 In the Groups  Treeview, click the right-hand mouse button on the group name 

Span Girder A and select the Select Members option from the menu. If you 

already have some features selected click Yes to deselect them first. 

 From the Attributes  Treeview, drag and drop the load attribute Thermal_Span 

Girder A onto the selected Lines. Make sure that the analysis option is set to 

Analysis 1 and the loadcase option is set Loadcase 1 to assign the properties into 

the first analysis. 

 Repeat these operations to make the following assignments: 

 In the  Treeview, 

Select Members of 

each group, clicking 

Yes to deselect any 

existing selection. 

 From the  

Treeview, drag and 

drop each named 

loading attribute  

onto the selected lines 

 Assign to 

Analysis 

 Assign to 

Loadcase 

 Span Girder B  Thermal_Span 

Girder B 

 Analysis 1   Loadcase 

1 

 Pier Girder 

Uncracked 

 Thermal_Pier 

Girder 

 Analysis 1   Loadcase 

1 

File 

Script > 

Run Script… 
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 Pier Girder 

Cracked 

 Thermal_Pier 

Girder 

 Analysis 1   Loadcase 

1 

 

Rename analysis 1 

 In the Analyses  treeview,  right-click on Analysis 1 and rename as Analysis 1 

Phase 3 Composite Variable Actions 

 In the  treeview, right-click on Loadcase 1 in Analysis 1 and rename as Thermal 

heat. 

Assigning Thermal Loading for Cooling Case 

 In the Groups  Treeview, click the right-hand mouse button on the group name 

Span Girder A and select the Select Members option from the menu. If you 

already have some features selected click Yes to deselect them first. 

 From the Attributes  Treeview, drag and drop the load attribute Thermal_Span 

Girder A onto the selected Lines. Make sure that the analysis option is set to 

Analysis 1. Then, using the loadcase select, select New from the drop-down list, 

and enter the name Thermal cool. Click OK. Then click the More button and enter 

the load factor as -1. 

 Repeat these operations to make the following assignments: 

 In the  Treeview, 

Select Members of 

each group, clicking 

Yes to deselect any 

existing selection. 

 From the  

Treeview, drag and 

drop each named 

loading attribute  

onto the selected lines 

 Assign to 

Analysis  

 Assign to 

loadcase  

 With a  

load 

factor of 

 Span Girder B  Thermal_Span 

Girder B 

 Analysis 1   Thermal 

cool 

 -1 

 Pier Girder 

Uncracked 

 Thermal_Pier 

Girder 

 Analysis 1   Thermal 

cool 

 -1 

 Pier Girder  Thermal_Pier  Analysis 1   Thermal 
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Cracked Girder  cool 

 -1 

 

Save the model 

 Save the model file. 

Tip. Before creating the other analyses or further loadcases it is good practice to check 

that Analysis 1 will solve without errors. 

Check the model will solve 

 Click the Solve now button and press OK to run the analysis using LUSAS Solver 

and load the results file. The deformed mesh plot for Analysis 1, loadcase Thermal cool 

is shown below. 

 

Once Analysis 1 has been checked to ensure that it solves without errors, the additional 

analyses and phases required for the design process can be added. 

File 

Save 
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Defining Analysis 2 Settlement and Shrinkage Loads 

 Ensure that the option Inherit from the base analysis (All) is checked (ticked). 

 Enter the analysis name as Analysis 2 Phase 2b Composite Settlement/Shrinkage, 

then press OK.  

This will create a second analysis that has the same engineering properties (geometric 

sections, materials properties and supports) as the base analysis, Analysis 1 Phase 3 

Composite Variable Actions.   

 In the Analyses  treeview,  right-click on Loadcase 2 in Analysis 2 and rename 

as Settlement. 

Assigning Geometric Properties in Analysis 2 

Currently Analysis 2 has inherited the section properties from Analysis 1.  These need 

to be changed as follows: 

 In the  

Treeview, Select 

Members of each 

group, clicking Yes 

to deselect any 

existing selection. 

 From the  Treeview, 

drag and drop each 

named geometric attribute 

 onto the selected lines 

 Assign to Analysis 

 Span Girder A  Span Girder A__F2b  Analysis 2 Phase 2b 

Composite 

Settlement/Shrinkage 

 Span Girder B  Span Girder B__F2b  Analysis 2 Phase 2b 

Composite 

Settlement/Shrinkage  

 Pier Girder 

Uncracked 

 Pier Girder__F2b  Analysis 2 Phase 2b 

Composite 

Settlement/Shrinkage  

 

Defining and Assigning Material Properties in Analysis 2 

The transverse slab geometric section properties have been inherited from the base 

analysis but it has also inherited the base material Concrete_short_term_Phase3.  This 

needs to be changed for analysis 2. 

Analyses 

Structural 
Analysis… 
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 In the  Treeview, click the right-hand mouse button on the group name 

Transverse Slab and select the Select Members option from the menu. If you 

already have some features selected click Yes to deselect them first. 

 From the Treeview, drag and drop the material attribute 

Concrete_long_term_Phase2b onto the selected Lines. Make sure that the 

analysis option is set to Analysis 2 Phase 2b Composite Settlement/Shrinkage to 

assign the properties into the second analysis. 

Defining and Assigning Loading in Analysis 2 

In the second analysis the settlement and shrinkage loads will be applied to the analysis 

model. 

A settlement of 10mm will be considered at the internal pier. 

 Select the Prescribed Displacement option and click Next. 

 Set the translation in the Z direction to Fixed, the displacement as Total, -0.01m. 

 Enter an attribute name of Settlement 10mm and click OK.  

 Select the four points at the internal pier 

location that have supports assigned to 

them. 

 From the  Treeview, drag and drop the 

point loading attribute Settlement 10mm 

onto the selected Points. Make sure that the 

load is applied into Analysis 2 Phase 2b 

Composite Settlement/Shrinkage and the loadcase Settlement. 

Next, the effects of shrinkage can be applied to the analysis. Earlier in the example the 

shrinkage effects were exported from the Composite Deck Designer (PontiEC4) into a 

file called “LUSAS_Shrinkage.vbs”. 

Locate the “LUSAS_Shrinkage.vbs” and open in LUSAS.  

 Select the file LUSAS_Shrinkage.vbs and press OK to open in LUSAS. 

This adds some shrinkage load attributes to the Attributes  Treeview as shown: 

Attributes 

Loading… 
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These attributes are to be renamed.  

 Right-click on each in turn and rename the label Ritiro with the word Shrinkage. 

 In the  Treeview, click the right-hand mouse button on the group name Span 

Girder A and select the Select Members option from the menu. If you already have 

some features selected click Yes to deselect them first. 

 Drag and drop the loading attribute Shrinkage_Span Girder A from the 

Treeview onto the selected Lines. Make sure that the analysis option is set to 

Analysis 2 Phase 2b Composite Settlement/Shrinkage to assign the properties 

into the second analysis.  Using the loadcase select, select New from the drop-down 

list, and enter the name Shrinkage. Click OK. 

 Repeat these operations to make the following assignments: 

 In the  

Treeview, Select 

Members of 

each group, 

clicking Yes to 

deselect any 

existing 

selection. 

 From the  

Treeview, drag and 

drop each named 

loading attribute  

onto the selected 

lines 

 Assign to 

Analysis 

 Assign to 

Loadcase 

 Span Girder B  Shrinkage_Span 

Girder B 

 Analysis 2 

Phase 2b 

Composite 

Settlement/

Shrinkage  

 Shrinkage 

 Pier Girder 

Uncracked 

 Shrinkage_Pier 

Girder 

 Analysis 2 

Phase 2b 

Composite 

Settlement/

Shrinkage  

 Shrinkage 

 Pier Girder  Shrinkage_Pier  Analysis 2 

Phase 2b 

 Shrinkage 
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Cracked Girder Composite 

Settlement/

Shrinkage 

 

Defining Analysis 3 Permanent Loads 

 Ensure that the option Inherit from the base analysis (All) is checked (ticked). 

 Enter the analysis name as Analysis 3 Phase 2a Composite Permanent, then press 

OK.  

 In the Analyses  treeview,  right-click on Loadcase 2 in Analysis 3 and rename 

as Surfacing. 

Assigning Geometric Properties in Analysis 3 

Currently Analysis 3 has inherited the section properties from Analysis 1. These need to 

be changed as follows: 

 In the  

Treeview, Select 

Members of each 

group, clicking Yes 

to deselect any 

existing selection. 

 From the  Treeview, 

drag and drop each 

named geometric attribute 

 onto the selected lines 

 Assign to Analysis 

 Span Girder A  Span Girder A__F2a  Analysis 3 Phase 2a 

Composite Permanent 

 Span Girder B  Span Girder B__F2a  Analysis 3 Phase 2a 

Composite Permanent 

 Pier Girder 

Uncracked 

 Pier Girder__F2a  Analysis 3 Phase 2a 

Composite Permanent 

 

Defining and Assigning Material Properties in Analysis 3 

The transverse slab geometric section properties have been inherited from the base 

analysis but it has also in inherited the base material Concrete_short_term_Phase3.  

This needs to be changed for analysis 3. 

Analyses 

Structural 
Analysis… 



Part 3: Building the LUSAS analysis model 

 39 

 In the Groups  Treeview, click the right-hand mouse button on the group name 

Transverse Slab and select the Select Members option from the menu. If you 

already have some features selected click Yes to deselect them first. 

 Drag and drop the material attribute Concrete_long_term_Phase2a from the 

Attributes  Treeview onto the selected Lines. Make sure that the analysis option 

is set to Analysis 3 Phase 2a Composite Permanent to assign the properties into 

the third analysis. Click OK. 

Defining and Assigning Loading in Analysis 3 

In the third analysis the permanent loads due to surfacing will be applied on the main 

girders.  

 Select the Global distributed option and click Next. 

 Set the type to Per unit length, the Z direction as -8700 N/m. 

 Enter an attribute name of Weight of Surfacing and click Finish.  

 In the  Treeview, click the right-hand mouse button on the group name Main 

Girders and select the Select Members option from the menu. If you already have 

some features selected click Yes to deselect them first. 

 From the Treeview, drag and drop the loading attribute Weight of Surfacing 

onto the selected Lines. Make sure that the load is applied into Analysis 3 Phase 2a 

Composite Permanent and the loadcase Surfacing. 

Defining Analysis 4 Permanent Loads 

 Ensure that the option Inherit from the base analysis (All) is checked (ticked). 

 Enter the analysis name as Analysis 4 Phase 1 Non-Composite Self Weight, then 

press OK.  

 In the Analyses  treeview,  right-click on Loadcase 1 in Analysis 4 and rename 

as Steel Self Weight. 

Assigning Geometric Properties in Analysis 4 

Currently Analysis 4 has inherited the section properties form Analysis 1.  These need 

to be changed as follows: 

 In the  

Treeview, Select 

Members of each 

 From the  Treeview, 

drag and drop each 

named geometric material 

 Assign to Analysis 

Attributes 

Loading… 

Analyses 

Structural 
Analysis… 
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group, clicking Yes 

to deselect any 

existing selection. 

attribute  onto the 

selected lines 

 Span Girder A  Span Girder A__F1  Analysis 4 Phase 1 

Non-Composite Self 

Weight 

 Span Girder B  Span Girder B__F1  Analysis 4 Phase 1 

Non-Composite Self 

Weight 

 Pier Girder 

Uncracked 

 Pier Girder__F1  Analysis 4 Phase 1 

Non-Composite Self 

Weight 

 Pier Girder 

Cracked 

 Pier Girder__F1  Analysis 4 Phase 1 

Non-Composite Self 

Weight 

 

Defining and Assigning Deactivation dataset in Analysis 4 

Currently the Transverse Slab has the material properties of 

Concrete_short_term_Phase3 which have been have been inherited from the base 

analysis. Analysis 4 is only going to consider the steel girder sections on their own with 

the Transverse Slab being deactivated. Therefore it is not important what material 

properties the Transverse Slab has in Analysis 4. 

The Transverse Slab will be deactivated by using the activate and deactivate facility 

within LUSAS.  

 Select the Deactivate option and click Next  

 Select the Percentage to redistribute option and leave the value as 100%. Enter 

the attribute name as Deactivate, then press Finish  

 

 In the  Treeview, click the right-hand mouse button on the group name 

Transverse Slab and select the Select Members option from the menu. If you 

already have some features selected click Yes to deselect them first. 

 From the Treeview, drag and drop the deactivation attribute Deactivate onto the 

selected Lines. Make sure that the analysis option is set to Analysis 4 Phase 1 Non-

Composite Self Weight and the loadcase Steel Self Weight. 

Attributes 

Activate and 
Deactivate… 
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Defining and Assigning Loading in Analysis 4 

In the fourth analysis the dead load of the steel beams and the weight of the concrete 

acting on the main girders will be considered. 

 Select the Body Force option and click Next. 

 Enter an acceleration of -9.81 in the Z direction.  

 Enter an attribute name of Gravity and click Finish.  

 Select the Global distributed option and click Next. 

 Set the type to Per unit length, the Z direction as -22685 N/m. 

 Enter an attribute name of Weight of Slab and click Finish.  

 In the  Treeview, click the right-hand mouse button on the group name Main 

Girders and select the Select Members option from the menu. If you already have 

some features selected click Yes to deselect them first. 

 From the  Treeview, drag and drop the loading attribute Gravity onto the 

selected Lines. Make sure that the analysis option is set to Analysis 4 Phase 1 Non-

Composite Self Weight and loadcase Steel Self Weight. 

 With the members of the group Main Girders still selected, drag and drop the 

loading attribute Weight of Slab from the  Treeview onto the selected Lines. 

Make sure that the analysis option is set to Analysis 4 Phase 1 Non-Composite 

Self Weight and using the loadcase selection, select New from the drop-down list, 

and enter the name Concrete Self Weight. Click OK. 

Additional Traffic load patterns 

Now that the basic analysis models have been defined, the additional Traffic load 

Patterns can be created. 

In order to use the vehicle load optimisation facility the locations (points or nodes) at 

which the optimised load patterns are to be created need to be selected as well as the 

LUSAS component of interest.  

To do this, influence attributes are defined and assigned to the model. LUSAS then 

calculates the influence surfaces for any specified position in the structure. Two 

methods are available: the Reciprocal Method and the Direct Method. Since in this 

example only two locations are going to be considered the Reciprocal method will be 

used. See the Online Help for details of these two methods. 

Note. Only two locations are going to be considered as this example is only 

considering two locations for detailed design.  In reality many locations would need to 

Attributes 

Loading… 

Attributes 

Loading… 
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be considered to cover the full design of the bridge, but for clarity this simplification 

will be accepted. The design checks will be carried out along girder 2, at the middle of 

span 1 and also over the pier support.  

Defining Influence Attributes 

The first influence attribute will be used to investigate the bending moment at near the 

middle of span 1 on girder 2. 

 Select a Moment influence type for an About transverse influence direction for a 

Negative displacement direction. Enter the influence attribute name as Sagging 

moment and click OK. The influence attribute will be added to the Treeview. 

The second influence attribute will be used to investigate the bending moment over the 

pier on girder 2. 

 Select a Moment influence type for an About transverse influence direction for a 

Positive displacement direction. Enter the influence attribute name as Hogging 

moment and click OK. The influence attribute will be added to the Treeview. 

Assigning Influence Attributes 

Influence attributes will be assigned at the middle of span 1 on girder 2, and at the pier 

on girder 2. See image that follows. 

 

 Select the Point (10.5, 3.7) as shown on girder 2. 

 From the  Treeview, drag and drop the influence attributes Sagging moment 

onto the selected Point. This will automatically be assigned into a new Reciprocal 

Influence Analysis. 

 Select the Point 28.0, 3.7) at the pier on girder 2. 

 From the  Treeview, drag and drop the influnce attributes Hogging moment onto 

the selected Point. This will automatically be assigned into a new Reciprocal 

Influence Analysis. 

Attributes 

Influence > 

Reciprocal… 

Attributes 
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Visualising the Defined Influence Points 

Influence attribute assignments are visualised as they are assigned to the model. To 

check that the influence attribute orientations are correct (meaning that the correct 

influence directions have been defined) an isometric view of the model should be used.  

 

 Select the isometric button.  

 

 Ensure that the influence visualisations are as shown  

 

Using the Vehicle Load Optimisation facility to calculate 

the worst case traffic loading patterns 

The vehicle load optimiser automates the creation of load datasets in accordance with 

the chosen loading code for the locations and effects specified.  

Before invoking the Vehicle Load Optimisation Wizard the kerb lines need to be 

defined.  

 Select the Home button to return the model to the default view. 

Defining Kerb Lines 

 Enter coordinates of (-5, 0.9), and (61.0, 0.9), to define a line representing one of 

the kerbs, and click OK. 

 Enter coordinates of (-5, 10.2), and (61.0, 10.2), to define a line representing the 

other kerb, and click OK. 

Geometry > 

Line > 

Coordinates… 

Geometry > 

Line > 

Coordinates… 
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 Select the first and second kerb line. (Use the Shift key to add to the initial 

selection)  

 

Vehicle Load Optimisation 

Now that influence attributes have been defined and assigned, the VLO facility can be 

used to define optimised traffic loading for the bridge, based on a chosen code of 

practice. For this example design code EN1991-2 UK will be used. In this code, normal 

traffic is represented by Load Model 1 (LM1). 

For the road carried by this bridge, the highway authority has also specified that the 

abnormal traffic be represented by the special vehicle SV100, as defined in the UK 

National Annex. 

It will be assumed that the traffic loading will be the leading variable action and 

therefore only characteristic and frequent values will be considered within the VLO 

facility. 

 Ensure that the lines representing the kerbs are still selected 

 Select United Kingdom from the Country drop down list and choose EN1991-2 

UK 2009 as the Design code. 

 Press the Optional Code settings button and ensure that only Characteristic and 

Frequent representative values required are checked (ticked).  Ensure that Group 

1a –LM1, Group 4 –LM4 and Group 5 –LM3 load groups are to be included.  

For the vehicle selector, press the button and deselect the SV80 option and select 

the SV100 vehicle only.  Press OK to exit the dialog. 

 Press the Define carriageways button. Ensure Kerbs from selection is selected 

and press Apply to exit the dialog. 

 Press the Set influence surfaces button, and on the next dialog select Include all 

influence surfaces. 

 Ensure that the Positive checkboxes are selected for both the Sagging and Hogging 

moment. This means that the VLO analysis will produce loading patterns for 

positive regions of the influence shape. 

Bridge 

Vehicle Load 
Optimisation 
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Note. Clicking in the header cell of a column will select the whole column so that 

checking (ticking) one entry will check (tick) all entries in that column.  

 Press OK to return to the main VLO dialog. 

 Ensure the option to View onerous effect table is not selected. 

 Ensure the option to Create loading patterns for All chosen influences is selected. 

 To specify a non-default analysis name choose New from the drop-down list, and 

enter the analysis name to be VLO Analysis 5  

 Change the VLO run Name to be VLO Eurocode 

 Press OK which will run generate the optimised loading patterns for the influence 

points of interest. 

After a short time, and at the bottom of the  Treeview, a new entry VLO Analysis 5 

will be created. This contains the loading from  VLO run, as denoted by this icon, 

, which includes Characteristic and Frequent load combinations for the locations 

requested. 

 By setting a loadcase active and turning on the  loading, the traffic loading 

patterns for each influence result can be seen. 

  

Loading pattern  

for influence result in span 1 for loadcase 

 Sagging moment - Positive - Characteristic 

Loading pattern  

for influence result at pier for loadcase  

Hogging moment – Positive - Characteristic 

 

 Save the model file. 

Solve the model 

 Click the Solve now button and press OK to run all the analyses using LUSAS 

Solver and load the results file. 




File 

Save 



Composite Highway Bridge Design 

 
 

46 

Combinations and envelopes 

Now that all the Analyses and their respective load cases have been created, 

combinations and envelopes for each Phase and for each Limit State the can be defined.  

Four cases will be defined, ULS Fundamental, SLS Characteristic, SLS Frequent 

and Fatigue.  

Before the limit state combinations can be created some initial envelopes need to be 

created. 

 Include the Thermal heat and the Thermal cool loadcases from Analysis 1. 

 Click the  button to add these loadcases to the included list.  

 Change the envelope name to Thermal Envelope 

Click the OK button to complete the definition and create a envelope in the  

Treeview. 

Repeat the above steps for the following envelopes 

Note. The loadcase names used below will depend on exact point selected in model 

and how the model was constructed. Therefore the loadcase names might have different 

point numbers in the name string. 

 Include the Sagging moment - Point 76 - Positive – Characteristic and the 

Hogging moment - Point 86 - Positive – Characteristic loadcases from Analysis 

5, change the name to Characteristic Envelope and click OK. 

 Include the Sagging moment - Point 76 - Positive – Frequent and the Hogging 

moment - Point 86 - Positive – Frequent loadcases from Analysis 5, change the 

name to Frequent Envelope and click OK. 

Limit state Combinations 

Before creating the combinations the way that the factors are displayed will be changed. 

 In the  Treeview double-click on the  Combinations and envelope options, 

and ensure that the option Display beneficial/adverse factors for smart 

combinations is selected (checked). 

Note. If the last action is not undertaken the smart combination will show factors as 

permanent and variable. Permanent load factor is always applied and a Variable load 

Analyses 

Envelope... 



Analyses 

Envelope... 

Analyses 

Envelope... 


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factor is only applied if the effect is adverse. The option that is set changes the dialog 

Permanent/Variable to Beneficial/Adverse. 

The following table shows the analyses and the loadcases that they contain – the 

loadcases that will be combined to form the required limit state combinations. 

Analysis Construction 

Phase 

Loadcase 

Analysis 4 Phase 1 Steel Self Weight 

Concrete Self Weight 

Analysis 3 Phase 2a Surfacing 

Analysis 2 Phase 2b Settlement 

Shrinkage 

Analysis 1 Phase 3 Thermal heat 

Thermal cool 

Analysis 5 VLO using 

properties from 

Phase 3 

Sagging moment - Point 76 - Positive – Characteristic  

Sagging moment - Point 76 - Positive – Frequent 

Hogging moment - Point 86 - Positive – Characteristic 

Hogging moment - Point 86 - Positive – Frequent 

 

Note. In this example the number of loadcases included into each construction phase 

has been kept to a minimum to ensure the example is as concise as possible but still 

covers the basics of what is required. It is recognised that further actions could be 

included in each of the construction phases, for example Analysis 5 could include the 

variable action Wind. However, it is intended that this example shows the process of 

using the Composite Deck Designer (PontiEC4) with LUSAS from start to finish. Once 

this is understood additional actions can easily be fitted into the process. 

The following table shows the envelopes that will also be combined with the basic 

loadcases to form the required limit state combinations. 

Envelope Envelope loadsets 

Thermal Envelope Thermal Envelope (Max) 

Thermal Envelope (Min) 

Characteristic Envelope Characteristic Envelope (Max) 

Characteristic Envelope (Min) 

Frequent Envelope Frequent Envelope (Min) 

Frequent Envelope (Max) 


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ULS Combinations 

The factors in the combinations will be based on the traffic loading being the leading 

variable action. 

ULS_Fundamental_Phase1 

This creates a smart load combination in the  Treeview. 

 Include the Steel and Concrete Self Weight loadcases from Analysis 4 in the smart 

combination.  

 Click the  button to add these loadcases to the included list.  

 Set the permanent and variable factors as shown in bold in the table that follows:  

Name Beneficial factor Adverse factor 

Steel Self Weight 

Concrete Self Weight 

0.95 

0.95 

1.2 

1.35 

 

Values are taken from UK NA to EN1990: Table NA.A2.4(B) Design Values For 

Actions.    Steel Self weight γG,sup = 1.20 and γG,inf = 0.95 and Concrete Self weight γG,sup 

= 1.35 and γG,inf = 0.95 

 Change the smart combination name to ULS_Fundamental_Phase1 and Click OK. 

 Repeat the above procedure for the following smart combinations: 

ULS_Fundamental_Phase2a 

Name Beneficial factor Adverse factor 

Surfacing 0.95 1.2 

 

Values are taken from UK NA to EN1990: Table NA.A2.4(B) Design Values For 

Actions.    Road Surfacing γG,sup = 1.20 and γG,inf = 0.95 

 Enter smart combination name: ULS_Fundamental_Phase2a 

Analyses 

Smart 
Combination... 
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ULS_Fundamental_Phase2b 

Name Beneficial factor Adverse factor 

Settlement 

Shrinkage 

0.0 

0.0 

1.2 

1.0 

 

Values are taken from UK NA to EN1990: Table NA.A2.4(B) Design Values For 

Actions.    Settlement γG,sup = 1.20 and γG,inf = 0.0.  The Partial factor for shrinkage γShr 

is set to unity for both ULS and SLS by EN 1992-1-1, Clause 2.4.2.1. 

No clear guidance is given on factors for shrinkage but in this example it will be 

considered γG,sup = 1.20 and γG,inf = 0.0 

 Enter smart combination name: ULS_Fundamental_Phase2a 

ULS_Fundamental_Phase3a 

Name Beneficial factor Adverse factor 

Thermal Envelope (Max) 

Thermal Envelope (Min) 

0 

0 

1.55*0.6 

1.55*0.6 

 

Values are taken from UK NA to EN1990: Table NA.A2.4(B) Design Values For 

Actions.    Thermal γG,sup = 1.55 and γG,inf = 0.0 and  Table NA.A2.1 – Recommended 

values of ψ factors for road bridges ψ0=0.6. This can be entered and will be evaluated 

by Modeller as 1.55*0.6 

 Enter smart combination name: ULS_Fundamental_Phase3a 

ULS_Fundamental_Phase3b 

Name Beneficial factor Adverse factor 

Characteristic Envelope 

(Max) 

Characteristic Envelope (Min) 

0 

0 

1.35 

1.35 

 

Values are taken from UK NA to EN1990: Table NA.A2.4(B) Design Values For 

Actions.    Road Traffic γG,sup = 1.35 and γG,inf = 0.0.  Note the Vehicle Load Optimiser 

has already included the appropriate ψ values from Table NA.A2.1. 
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 Enter smart combination name: ULS_Fundamental_Phase3b 

SLS Combinations  

SLS_ Characteristic_Phase1 

Name Beneficial factor Adverse factor 

Steel Self Weight 

Concrete Self Weight 

1.0 

1.0 

1.0 

1.0 

 

Values are taken from EN 1990 Clause: 6.5.3 (2) 

 Enter smart combination name: SLS_Characteristic_Phase1  

SLS_ Characteristic_Phase2a 

Name Beneficial factor Adverse factor 

Surfacing 1.0 1.0 

 

Values are taken from EN 1990 Clause: 6.5.3 (2) 

 Enter smart combination name: SLS_ Characteristic_Phase2a 

SLS_ Characteristic_Phase2b 

Name Beneficial factor Adverse factor 

Settlement 

Shrinkage 

0.0 

0.0 

1.0 

1.0 

 

Values are taken from EN 1990 Clause: 6.5.3 (2). The Partial factor for shrinkage γShr 

is set to unity for both ULS and SLS by EN 1992-1-1, Clause 2.4.2.1. 

 Enter smart combination name: SLS_Characteristic_Phase2b 

SLS_ Characteristic_Phase3a 

Name Beneficial factor Adverse factor 



Part 3: Building the LUSAS analysis model 

 51 

Thermal Envelope (Max) 

Thermal Envelope (Min) 

0 

0 

1.0 x 0.6 

1.0 x 0.6 

 

Values are taken from EN 1990 Clause: 6.5.3 (2) and  Table NA.A2.1 – Recommended 

values of ψ factors for road bridges ψ0=0.6. 

 Enter smart combination name: SLS_Characteristic_Phase3a 

SLS_Characteristic_Phase3b 

Name Beneficial factor Adverse factor 

Characteristic Envelope 

(Max) 

Characteristic Envelope (Min) 

0 

0 

1.0 

1.0 

 

Values are taken from EN 1990 Clause: 6.5.3 (2) 

 Enter smart combination name: SLS_Characteristic_Phase3b 

SLS_ Frequent_Phase1 

Name Beneficial factor Adverse factor 

Steel Self Weight 

Concrete Self Weight 

1.0 

1.0 

1.0 

1.0 

 

Values are taken from EN 1990 Clause: 6.5.3 (2) 

 Enter smart combination name: SLS_Frequent_Phase1  

SLS_ Frequent_Phase2a 

Name Beneficial factor Adverse factor 

Surfacing 1.0 1.0 

 

Values are taken from EN 1990 Clause: 6.5.3 (2) 

 Enter smart combination name: SLS_ Frequent_Phase2a 
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SLS_ Frequent_Phase2b 

Name Beneficial factor Adverse factor 

Settlement 

Shrinkage 

0.0 

0.0 

1.0 

1.0 

 

Values are taken from EN 1990 Clause: 6.5.3 (2). The Partial factor for shrinkage γShr 

is set to unity for both ULS and SLS by EN 1992-1-1, Clause 2.4.2.1. 

 Enter smart combination name: SLS_Frequent_Phase2b 

SLS_ Frequent_Phase3a 

Name Beneficial factor Adverse factor 

Thermal Envelope (Max) 

Thermal Envelope (Min) 

0 

0 

1.0 x 0.5 

1.0 x 0.5 

 

Values are taken from EN 1990 Clause: 6.5.3 (2) and  Table NA.A2.1 – Recommended 

values of ψ factors for road bridges ψ2=0.5. 

 Enter smart combination name: SLS_Frequent_Phase3a 

SLS_Frequent_Phase3b 

Name Beneficial factor Adverse factor 

Frequent Envelope(Max) 

Frequent Envelope (Min) 

0 

0 

1.0 x 0.75 

1.0 x 0.75 

 

Values are taken from EN 1990 Clause: 6.5.3 (2) and Table NA.A2.1 – Recommended 

values of ψ factors for road bridges ψ1=0.75 

 Enter smart combination name: SLS_Frequent_Phase3b 
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Fatigue Combinations  

Note. For the Fatigue case the Load Model 1 are similar to those defined for the 

Frequent loading, therefore this will be used for the Fatigue limit state.   However the 

Fatigue Load Model 1 is defined in with the values of the axle loads equal to 0,7Qik 

and the values of the uniformly distributed loads equal to ik 0,3q. Therefore using the 

load patterns created by the VLO facility without modification would be excessively 

conservative.  However to save time in this example an assumed load reduction factor 

will be applied to the whole load pattern in a combination with a factor of 0.5.  This is a 

gross assumption for the example and in reality the correct loading should be defined.  

Name Beneficial factor Adverse factor 

Frequent Envelope(Max) 

Frequent Envelope (Min) 

0 

0 

1.0 x 0.5 

1.0 x 0.5 

 
 Enter smart combination name: Fatigue 

Running the model 

 Save the model file. 

Solve the model 

 Click the Solve now button and press OK to run the analysis using LUSAS Solver 

and load the results file. 

View initial results 

Once the model has been solved the results can be viewed within LUSAS Modeller to 

create bending moment diagrams etc.  To show how this is done: 

 In the Analyses  treeview, set active loadcase ULS_fundamental_Phase3b 

(Min), choose entity Force/Moment and component My 

 Right-click in the view window and add the Diagrams layer, selecting entity 

Force/Moment and component My. Ensure Show minimum only is selected, and 

click OK. 

 In the Groups  treeview, right click on Main Girders and select Set As Only 

Visible. 



File 

Save 
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This worked example will not carry out any other processing or viewing of results 

within LUSAS Modeller, instead the results will be exported back to the Composite 

Deck Designer (PontiEC4) where the detailed design checks will be made. 

Part 4: Exporting the force and moment data from LUSAS to 

the Composite Deck Designer (PontiEC4) 

 

Associated File 

This supplied file is only for use in case of problems in manually creating the 

appropriate data in the previous section of the example. 

 Force_and_Moments.xls  File created by the LUSAS Export Forces and 

Moments dialog containing data to import into PontiEC4. 

Selection of elements for checking 

As discussed earlier, for simplicity only two locations will be considered for detailed 

design. In reality many locations would need to be considered to cover the full design 

of the bridge. The design checks will be carried out along girder 2, near the middle of 

span 1 and also over the pier support. 

 In the View window, right-click and select All Visible. 


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 Turn off the display of the Diagrams layer 

 Turn on the display of the Mesh layer 

 Select the elements along girder 2, at the middle of span 1, and also over the pier 

support as shown on the following image. 

Note. To select the elements with the geometry still visible use the Select Elements 

toolbar button  to only select the elements required, holding down the Shift key to 

add to the initial selection.  Depending on how the model was constructed the exact 

element and node numbers might be different from those showing in this example. 

 

With the elements selected, the results for just these elements can be exported 

 Select the Design > Export to Composite Deck Design …menu item. 

 In the Analysis selection dialog that appears, select Analysis 1 Phase 3 Composite 

Variable Actions from the drop-down list provided, and click OK. The chosen 

analysis will be used to determine if sections are cracked or un-cracked. 

 


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 On the Export Forces and Moments dialog, choose the Selected Sections tab. These 

sections have been defined based on the elements selected prior to selecting the 

Bridge> Composite Deck Designer> Export… menu item. 

 

For each selected element, the table defines two sections, representing the first and last 

Gauss points. Each Section name listed has the following information: Element 

(number), Gauss point (number), Cracked/uncracked section status.  

The section names in this table are created from the following named objects/values in 

the LUSAS model: 

“[Segment Name]+“_”+ “[Element number]+“_”+[Gauss Point Number] 

Important. The Export Forces and Moments facility obtains the segment and 

the phase name from the name of the assigned geometric attribute, by splitting the 

attribute name on the double underscore separator “__”. For this reason the 

cross-section geometric properties in any associated LUSAS model must have a 

name that follows this standard:  

[Segment Name] +”__”+ [Phase name]; where the phase name should be: {F1, 

F2a, F2b, F3a, F3b, cracked}. 

The cracked status of the section is a Boolean value taken as true when the phase 

name is “cracked”, and false otherwise. 


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 Click the “Loadcase Details” tab. 

On the Loadcase Details tab the design combinations, design limit states and phases are 

to be stated, along with the specification of shrinkage/thermal coefficients and 

component values of interest. 

 

To assemble a design combination, proceed as follows: 

 In the left-hand panel select ULS_Fundamental_Phase1, select a Design limit state 

of ULS_Fundamental, and from the Phase drop-down list select Phase 1. Click the 

‘Add to’ button   to add the design combination to the right-hand panel 

 Repeat the above sequence for all combinations listed in the table that follows, 

(noting that Phase 2c is not used) by selecting a Basic / smart combination and the 

corresponding Design limit state and Phase for each one. 

Basic / Smart combination Design limit state Phase 

ULS_Fundamental_Phase1 ULS Fundamental Phase 1 

ULS_Fundamental_Phase2a ULS Fundamental Phase 2a 

ULS_Fundamental_Phase2b ULS Fundamental Phase 2b 

ULS_Fundamental_Phase3a ULS Fundamental Phase 3a 

ULS_Fundamental_Phase3b ULS Fundamental Phase 3b 
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Basic / Smart combination Design limit state Phase 

SLS_Characteristic_Phase1 SLS Characteristic Phase 1 

SLS_Charactersitic_Phase2a SLS Characteristic Phase 2a 

SLS_Characteristic_Phase2b SLS Characteristic Phase 2b 

SLS_Characteristic_Phase3a SLS Characteristic Phase 3a 

SLS_Characteristic_Phase3b SLS Characteristic Phase 3b 

SLS_Frequent_Phase1 SLS Frequent Phase 1 

SLS_Frequent_Phase2a SLS Frequent Phase 2a 

SLS_Frequent_Phase2b SLS Frequent Phase 2b 

SLS_Frequent_Phase3a SLS Frequent Phase 3a 

SLS_Frequent_Phase3b SLS Frequent Phase 3b 

SLS_Frequent_Phase1 Fatigue Phase 1 

SLS_Frequent_Phase2a Fatigue Phase 2a 

SLS_Frequent_Phase2b Fatigue Phase 2b 

SLS_Frequent_Phase3a Fatigue Phase 3a 

Fatigue Combination Fatigue Phase 3b 

 

 Input a Shrinkage coefficient of 1.0 for the ULS and SLS. 

 Input a Thermal coefficient of 1.35x0.6=0.93 for the ULS and 1.0x0.6=0.6 for the 

SLS  

 In the ‘Component to maximize/minimize’ panel ensure Fz and My are checked. 

(These are the components that will be considered in the smart combinations) 

 Click the ellipsis button  to choose the folder and name of the xls file to create 

(e.g.: <current work directory>\Forces_and_moments.xls), pressing the Save 

button to return to the main dialog. 

 Click the Save button on the bottom-left of the dialog to save the data entered in the 

dialog pages for any possible re-use. Save the input as 

“Export_Forces_to_PontiEC4.inp”.  

Then, finally, click OK to create the XLS file for use in PontiEC4. 
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Part 5: Importing force and moment data to the Composite 

Deck Designer (PontiEC4) and assessing design results 

 

Associated File 

This supplied file is only for use in case of problems in manually creating the 

appropriate data in the previous section of the example. 

 Forces_and_moments.xls  File created by the LUSAS Export Forces 

and Moments dialog containing data to import into PontiEC4. 

 LUSAS_Comp_Bridge.csv - the input file for PontiEC4 with data on 

sections and materials. 
  
  

Importing force and moment data into PontiEC4 

This section covers the import of section force and moment data from LUSAS into 

PontiEC4. Refer to the “Forces and moments” section in the PontiEC4 online help file 

for more information.  

Whilst it is possible to manually enter forces and moments into PontiEC4 in the “Forces 

and moments” dialog, and it is also possible to copy and paste data into each section, 

when used with LUSAS any importing of data is far better achieved by using the 

automated procedure as follows. 

 In PontiEC4, with the current data still loaded (or with the data from the previously 

saved file “LUSAS_Comp_Bridge.csv” loaded if the example had been saved and 

closed for some reason at that point), select the File> Import forces/moments 

menu item and load the file Forces_and_moments.xls from working project folder. 

PontiEC4 will detect that four additional sections are present (these are the sections at 

the beginning and end of each beam element that was selected to signify a change of 

cross-section geometric property in the LUSAS model) and ask if they are to be added 

to their corresponding segments.  

 Click Yes to import the new sections. This operation 

may take a few seconds to complete. The status bar 

will show the progress. 

 From the main menu select Windows> 2 Geometry 

to display the Geometry dialog. In the Segment 

treeview the new sections added to each segment can 

be seen.  


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 If any previously defined initial sections for each segment (named Middle or Pier 

are present these are no longer necessary and should be deleted. To do this, select 

each section name in turn, click the right-hand mouse button, and choose Delete.  

 Also, any segment that does not have a section within 

it that is being used within the design checks can also 

be deleted. In this example no design checks are 

being carried out on the Span girder A segment so 

this should be deleted. To do this, select each 

segment name, click the right-hand mouse button, and 

choose Delete. This leaves the treeview as shown. 

Note. If any mistakes are made in deleting the unwanted sections, a re-import of 

the forces_and_moments.xls file will re-insert any deleted sections. 

 Select File> Save As and enter a file name of LUSAS_Comp_Bridge_Results.csv 

to save the PontiEC4 dialog data to the working project folder before 

proceeding to view the results.  

This concludes the data input. 

Assess the results and detailed design checks 

The design locations can now be assessed for Ultimate, Serviceability, and Fatigue limit 

states. It involves: 

1. Viewing utilisation factors for all checks performed 

2. Updating section sizes for any over-utilised sections 

3. Viewing updated results 

4. Updating the LUSAS model and re-analysing the revised sections 

It is usually enough to cycle through steps 1 to 4 once, or perhaps twice, to obtain an 

optimized structure. 

Limited details have been given about all the checks that are carried out. To find out 

more about the checks performed refer to the PontiEC4 online Help, where design code 

and theory details are also supplied. 

Viewing design results in PontiEC4 

 With the results loaded in PontiEC4 select the Window> Summary of results 

menu item. This carries out the design computations in PontiEC4 and displays the 

results for deck sections in a summary form.  

 


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The meaning of the coloured utilization factor entries is explained in the following 

table: 

Colour of value / text Utilization factor Meaning 

Red Greater than 1.0 Value has failed the check carried out. 

Green  Less than 1.0 Value has passed the check carried out. 

Grey - without parentheses Any Value of potential interest but the utilisation factor 

is not relevant to the code.  

(Grey) - with parentheses Any Value of potential interest but the utilisation factor 

is not relevant to the code in this particular context. 

Grey stating ‘No int.’ Not applicable No interaction between bending and shear. 

 

A check of the utilization factors obtained should be made for each limit state. Only a 

check for the Fundamental ULS combination will be shown here.  

Note. By clicking on a particular header the values in a column can be sorted in 

increasing or decreasing value 

 

Note. Changing from the Geometry, Materials or Forces and moments dialogs to the 

Results, Summary of results, Report, or Cracking dialogs causes a re-analysis of results. 

It can be seen that the summary of the results page is showing that ULS and SLS checks 

have passed Green but the Fatigue combination has a number of Red Fails.   

 Select the Window> Results menu item in order to find out more about the failed 

checks.  




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 In the Cross-sections and design combinations panel select section Span Girder 

B_41_1 and FLS steel, Mmax 

 

 Then, in the lower part of the Results dialog, select the FLS steel tab: 

 

The fatigue failures could be down to an underlying weakness in the Fatigue strength of 

the structure, however it is generally considered that Fatigue Load Model 1 is 

conservative, and if Fatigue Load Model 3 were considered instead, a better result 

would be obtained. Therefore it is recommended that the load model used for the 

Fatigue case be changed to adopt Fatigue Load Model 3. 

Part 6: Viewing optimised results 

Associated File 

 Forces_and_moments_optimised.xls  File created by the LUSAS 

Export Forces and Moments dialog containing data to import into 

PontiEC4. 

 


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The supplied file “Forces_and_moments_optimised.xls” is from a modified LUSAS 

analysis model where the simplified fatigue loading using Fatigue Load Model 1 has 

been replaced by the Fatigue Load Model 3. This was done by using the static vehicle 

library and the LUSAS moving load facility to drive the single Fatigue Load Model 3 

along the bridge deck above girder 2. These results were then enveloped to create the 

fatigue combination. 

 In PontiEc4, select the File> Import forces/moments menu item and load the file 

Forces_and_moments_optimised.xls from working project folder. 

 Select the Window> Summary of results menu item. 

 

It can then be seen that with the modified fatigue combination all sections pass ULS, 

SLS and Fatigue checks (with the exception of Span Girder B_41_11 – which just 

exceeds unity). 

Obtaining more detailed results 

 With the optimised data still loaded, select the Window> Results menu item.  

 In the ‘Cross-sections and design combinations’ panel, select section Span Girder 

B_41_1 and Fund. ULS, Mmin.  

 Select the Stresses tab to have a look at the elastic stresses on the gross section. 

 Then, select the Plastic check tab. From this, all details about the classification and 

plastic check are supplied, and it can be seen that for Stage 3, this section, that is 

part of the segment in the middle of the span, is in Class 1. 
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Note. At the bottom-left of the Plastic check page the section classification is also 

provided for Phase 1, where the top (upper) flange cannot be considered to be 

restrained by the slab. For this case, the section is in Class 4 as highlighted in the red 

message. For this situation a check of stresses in Phase 1 should be performed, using an 

effective section rather than a gross section.  

Creating Graphs 

 In PontiEC4, with the optimized data still loaded, select the Utilities> Graphs 

menu item.  

 From the first drop-down list choose ULS: Studs utilization ratio to plot the 

following graph: 


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Note. In this example the graph is only being drawn over part of the length of the 

girder because segment Span Girder A was deleted as it has no design section in it.  If 

all segments had been left in, the graph would be across the whole girder. 

Creating Reports 

 In PontiEC4, with the optimized data still loaded, select the Window > 6 Report 

menu item.  

 For section Span Girder B_41_1 check (tick) to select all optional design checks, 

and then select the Create report button at the bottom-right corner of dialog. 

 

 Enter a suitable file name for the report in this case Span Girder B, and then press 

the Save button to create the report. 

 

This completes the example. 


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