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Introduction to 

LUSAS Worked 

Examples 

Where do I start? 

Start by reading this introduction in its entirety. It contains useful general information 

about the LUSAS Modeller user interface and details of how the examples are 

formatted. 

Software requirements 

The LUSAS software version, software product (and type of that product) and any 

product options that are required in order to run an example will be stated in a usage 

box at the beginning of each worked example, like this: 

For LUSAS version: <will be stated here> 

For software product(s):  <will be stated here> 

With product option(s): <will be stated here> 

<Additional text relating to the use of the example may be stated here> 

 

Notes: 

 The LUSAS Academic software product will run any LUSAS modelling example 

provided the correct product option is selected during start-up. 

 LUSAS Analyst or LUSAS Composite products can run bridge or civil modelling 

examples if a Bridge or Civil product option was purchased.  

 Laminated composite modelling examples can be run in any software product if a 

Composite product option has been purchased.  
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What software do I have installed? 

To find out which software product(s), which type of that product, and which software 

options are installed and licensed for your use run LUSAS and select Help > About 

LUSAS Modeller and press the Key Information button. This will display a dialog that 

lists the facilities and options supported by your software license. 

  

See the heading Running LUSAS Modeller for details of how to run LUSAS. 

About the examples 

Four introductory worked examples provided in the Getting Started manual (and 

provided also as part of a software installation) contain detailed information to guide 

you through the procedures involved in building a LUSAS model, running an analysis 

and viewing the results. One introductory example is provided for use with each of the 

current LUSAS software products, namely: Civil & Structural, Bridge, Analyst and 

Composite.  

Many other worked examples are also available. These are supplied as part of a 

software installation and can also be accessed via the LUSAS Modeller online help 

system. They can also be downloaded from the LUSAS website.  

The examples provided are of varying complexity and cover different modelling and 

analysis procedures. In order to become familiar with LUSAS it will benefit you to 

work through as many examples as possible, even if they have no direct bearing on your 

immediate analysis interests. 

Except where mentioned, examples are written to allow modelling and analysis to be 

carried out with the Teaching and Training version of LUSAS which has restrictions on 
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problem size. The Teaching and Training version / evaluation limits are currently set as 

follows: 

1000 

Nodes 

200 

Points 

500 

Elements 

3000  

Degrees of Freedom 

20  

Loadcases 

 

Because of the modelling and analysis limits imposed by the Teaching and Training 

version some examples may contain coarse mesh arrangements that do not necessarily 

constitute good modelling practice. In these situations these examples should only be 

used to illustrate the LUSAS modelling methods and analysis procedures involved and 

should not necessarily be used as examples of how to analyse a particular type of 

structure in detail.  

Format of the examples 

Headings 

Each example contains some or all of the following main headings: 

 Description contains a summary of the example, defining geometry, material 

properties, analysis requirements and results processing requirements. 
 

 Objectives states the aims of the analysis. 

 Keywords contains a list of keywords as an aid to selecting the correct 

examples to run.  

 Associated Files contains a list of files held in the \<Lusas Installation 

Folder>\Examples\Modeller directory that are associated with the example. 

These files can be used to open or build a model to skip to a certain part of an 

example, for instance, if you are only interested in the results processing stage, 

or to re-build models if you have problems with the one you have created. 

 Modelling contains procedures for defining the features and attribute datasets 

to prepare the LUSAS model file. Multiple model files are created in some of 

the more complex examples and these therefore contain more than one 

‘Modelling’ section. 

 Running the Analysis contains details for running the analysis and 

assistance should the analysis fails for any reason.  

 Viewing the Results contains procedures for results processing using 

various methods. 
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Menu item selection 

Menu entries to be selected in the Modeller user interface are shown as follows in this 

menu item ‘block’: 

This implies that the Geometry menu should be selected from the menu bar, followed 

by Point, followed by the Coordinates... option.  

Sometimes when a menu item is referred to in the body text of an example it is written 

using a bold text style. For example the menu entry shown above would be written as 

Geometry > Point > Coordinates... 

Toolbar buttons 

For certain menu items a toolbar button will also be shown to show the ‘short-cut’ 

option to the same command that could be used instead: 

The toolbar button for the Geometry > Point > Coordinates… command is 

shown here.  

User actions 

Any actions that you need to carry out are generally bulleted (an exception is when they 

are immediately to the right of a menu item block or a toolbar button). Any text that has 

to be entered is written in a bold text style as follows: 

 Enter coordinates of (10, 20). 

So the selection of a typical menu item (or the equivalent toolbar button) and the 

subsequent action to be carried out would appear as follows: 

Enter coordinates of (10, 20). 

 

Selecting the menu item, or the toolbar button shown will cause a dialog box to be 

displayed in which the coordinates 10, 20 should be entered. 

Filling-in dialogs 

For dialogs, a bold text style is used to indicate the text that must be entered. Items to 

be selected from drop-down lists or radio buttons that need to be picked also use a bold 

text style. For example:  

 In the New Model dialog enter the filename as frame_2d and click the OK 

button to finish. 

Geometry 

Point > 

Coordinates... 

 

Geometry 

Point > 

Coordinates... 
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Grey-boxed text  

Grey-boxed text indicates a procedure that only needs to be performed if problems 

occur with the modelling or analysis of the example. An example follows: 

Rebuilding a model 

 Start a new model file. If an existing model is open, Modeller will prompt for any  

un-saved data to be saved before opening the new file. 

Enter the file name as example 

To recreate the model, select the file example_modelling.vbs located in the \<LUSAS 

Installation Folder>\Examples\Modeller
 
directory. 

 

 

Associated Files / Visual Basic Scripts 

Each example may reference associated files that should be loaded or run during the 

course of an example. These include files such as model files, spreadsheets, data files as 

well as Visual Basic script files. These files are supplied on the release kit are installed 

into the \<Lusas Installation Folder>\Examples\Modeller directory.  

Updates to these files may occasionally be made between software releases, and if 

done, revised files will be made available for download from the User Area of the 

LUSAS website.  

Model files 

Depending upon your access rights it may be necessary to copy a supplied model file to 

another folder before it can be opened, and remove the read-only protection before it 

can be saved (by Modeller) to a new folder with the same name. 

VBS Files 

If results processing and not the actual modelling of an example is only of interest to 

you the VBS files provided will allow you to quickly build a model for analysis. These 

scripts are also for use when it proves impossible for you to correct any errors made 

prior to running an analysis of an example. They allow you to re-create a model from 

scratch and run an analysis successfully. For more details refer to the heading 'Creating 

a Model From The Supplied VBS files'. 

File 

New… 

File 

Script > 

Run Script... 
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Modelling Units 

At the beginning of each example the modelling units used will be stated something like 

this: 

“Units used are N, m, kg, s, C throughout” 

 
Model units are specified as part of the creation of a new model and are reported at all 

times in the status bar at the bottom of the Modeller window. Once set, for all dialogs 

with grid cells permitting dimensional input, the units expected are displayed as a 

tooltip when the cursor is hovered over the input cell. 

Timescale Units 

Timescale units are specified as part of the creation of a new model and can be changed 

on the Model Properties dialog. Choosing a timescale unit dictates how time-based 

values are displayed on dialogs during modelling, and how they are output when 

processing results 

Icons Used 

Throughout the examples, files, notes, tips and warnings icons may be found. They can 

be seen in the left margin. 

Files.  The diskette icon is used to indicate files used or created in an example. 

  

Note.  A note is information relevant to the current topic that should be drawn to your 

attention. Notes may cover useful additional information or bring out points requiring 

additional care in their execution. 

Tip.  A tip is a useful point or technique that will help to make the software easier to 

use.  

Caution.  A caution is used to alert you to something that could cause an inadvertent 

error to be made, or a potential corruption of data, or perhaps give you results that you 

would not otherwise expect. Cautions are rare, so take heed if they appear in the 

example.  

Running LUSAS Modeller 

 Start LUSAS Modeller from the start programs menu. This differs according to 

the operating system in use, but typically is done by selecting: 

'Start' > All Programs > LUSAS (version) > LUSAS Modeller 








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 A licence option will need to be selected in order to allow access to the software. 

The on-line help system will be displayed showing the latest changes to the software. 

 Close the on-line Help system window. 

(LUSAS Academic version only)  

 

 Select a LUSAS software product appropriate for the worked example that is to 

be carried out, and click the OK button. 

Creating a new model / opening existing model 

 

When running LUSAS for the first time the LUSAS Modeller Startup dialog will be 

displayed. This dialog allows either a new model to be created, or an existing model to 

be opened. 
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Note.  When an existing model is loaded a check is made by LUSAS to see if a results 

file of the same name exists. If so, you have the option to load the results for the opened 

model. 

Note.  If an existing model is loaded, that in a previous session caused a crash to 

occur in LUSAS Modeller, options are provided to help you to recover your model 

data. 

 

If you are creating a new model the New Model dialog will be displayed. 

 Enter information and make selections for the new model and click the OK 

button. 

Product specific menu entries for the selected software product in use e.g. Bridge or 

Civil etc will be added to the LUSAS Modeller menu bar. 

Saving model files 

The worked examples as written do not generally advise you in which folder to save a 

model. By default the New Model dialog will initially save files to the <LUSAS 

Installation Folder>\Projects directory. For the purposes of carrying out the various 




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examples of interest this is acceptable, but note that for real ‘live’ projects it is normally 

beneficial to save models in separate project folders, each named according to the 

individual project that will be undertaken. This can assist with backup and eventual 

deletion of data on a project-by-project basis. 

Specifying the saved location of results/intermediate files 

The LUSAS Configuration Utility can be used to specify where files created in the 

course of building a model are saved.  See the online help pages or Installation Guide 

for details of how to access this tool. Using this facility, the location of files that are 

created in the course of a building a model and running the various analyses associated 

with it can be specified as being: 

 Within a folder for each model, within a folder called "LusasFiles" This is 

the default setting. Note that the model file itself does not reside within the 

folder created.  

 Within a folder with the same name as the model Note that the model file 

itself does not reside within the folder created.  

 Within the same folder as the model (This was the Version 14.7 behaviour)  

 To a specified folder where the location can be defined by internal LUSAS 

tokens and ordinary text. For example, the token%ModelLocn% is substituted 

with the working current folder for the model; and %ModelName% is 

substituted with the model's file name. Relative links (e.g. ..\ to use the parent 

folder) can alternatively be specified. 

For the purposes of carrying out the worked examples these settings do not need to be 

changed. 

Creating a Model from the Supplied VBS Files  

If results processing and not the actual modelling of an example is only of interest, the 

VBS files provided will allow you to quickly build a model for analysis.  

Proceed as follows to create the model from the relevant VBS file supplied: 

 Start a new model file.  

 Enter the file name as example name and click OK 

 Select the file example_name_modelling.vbs located in the \<LUSAS 

Installation Folder>\Examples\Modeller
 
directory, or if you have downloaded, saved 

and unzipped any associated files for the LUSAS examples from the User Area of the 

LUSAS website, locate the relevant file on your system and open that instead. 

File 

New… 

File 

Script > 

Run Script... 



Introduction to LUSAS Worked Examples 

 10 

Note.  VBS scripts that create models automatically perform a File > Save menu 

command as the end. 

Some additional modelling may need to be carried out prior to an analysis being run. 

See individual examples for details. 

The LUSAS Modeller User Interface 

The image below shows the principal user interface components of LUSAS Modeller. 

 

View window 

 A View window shows the model according to user-defined settings made else 

where on the user interface. Multiple view windows may be set-up, and each 

may show the model from a different angle, using different visualization 

options, with or without results.  

 The image in a view window is built up from several drawing Layers as listed 

in the Layers  Treeview (see Main Panels below). Each layers draws over 

the top of the one before it. 

 A Datatip provides model-related information about whatever is under the 

cursor.  

 A Tool tip reports on uses of toolbar buttons or expected input for grid cells in 

dialogs etc.  





Creating a Model from the Supplied VBS Files 

 11 

 An optional View axis cube shows model orientation at all times and allows 

orienting the model to a chosen view. Note that the worked examples do not 

generally include or make reference to this axis cube. 

 

Main panels 

Each of the main panels has its own Treeview showing a list of objects of a particular 

type. There are panels of Layers, Groups, Attributes, Analyses, Utilities and Reports. 

Each object in a Treeview has its own functionality. This can be invoked using its own 

context menu, the main menu or the toolbar buttons. In summary: 

 The Layers  Treeview controls the display of model data and results data to a 

view window. Each drawing layer is responsible for drawing one particluar 

aspect of this data such as geometry, mesh, and attributes layers for instance. 

  The Groups  Treeview is used to store selected user-defined collections of 

objects (geometry, nodes or elements) under a collective name. 

 The Attributes  Treeview is used to store named collections of data that may 

be attached (assigned) to the model geometry, such as the element type and 

discretisation on the geometry; section properties and thicknesses; the materials 

used; how the model is supported or restrained; and how the model is loaded. 

 The Analyses  Treeview shows all analyses that have been defined including 

loadcases, eigenvalues, results, and control chapters. Also in this treeview are 

post-procressing concepts such as combinations and envelopes. 

 The Utilities  Treeview contains utility items used in the definition of model 

geometry or attributes, or to control an analysis, or to provide a particular 

functionality, such as to define a load combination or produce a report for 

example. 

 The Reports  Treeview contains a named reports, each of which is made up 

of multiple chapters. Chapters may be defined to view modelling information, 

results, screenshots and similar. 

Other main panels 

Two main panels provide details of properties and associativity for selected objects. 

The panels are hidden until accessed by a selecting a feature/object and choosing the 
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relevant context menu item for that feature/object. They can also be made visible by 

selecting the View > Main Panels menu item. The panels can be docked, and separate 

tabs are provided for each panel when done. Double-clicking a docked window will 

isolate it again. The panels are: 

 Properties - displays the current properties of selected geometry features 

(points, lines, surface, volumes) and selected mesh objects (nodes, edges, 

elements, faces). See Properties Panel for more information.  

 Hierarchy - shows the merge status, and lists the higher and lower order 

features/objects of a single selected geometry feature or mesh object. The type 

and feature number of the selected feature is shown. 

Context menus 

 A Context menu (displayed by pressing the right-hand mouse button with an 

object selected) provides access to additional functionality such as editing of 

data, control of visibility, visualisation of assignments, and selective control of 

results plotting on selected attributes. Context menus are provided for objects 

selected in the View Window, and most items in the various Treeview panels. 

Selection Panels 

 Selected Items This panel can be viewed using the View> Selection Panels > 

Selection menu item. Once visible it will contain a list of all currently selected 

items which may then be individually deselected. 

 Selection Memory This panel can be viewed using the View> Selection Panels 

> Memory menu item. Once visible it will contain a list of all items currently in 

Selection Memory which may then be individually deselected. 

 Cyclable Items This panel can be viewed using the View> Selection Panels > 

Cyclable Items menu item. Once visible it will contain a list of all cyclable 

items. Where multiple items could possibly be selected by the same mouse click, 

cycling is the process of stepping through those items one at a time. An item can 

then be individually selected or deselected. 

 Visible items This panel can be viewed using the View> Selection Panels > 

Visible Items menu item. Once opened it contains details of all visible items 

selected in the view window. 

Text Output Window 

 The Text Output Window provides continuous feedback during a modelling or 

analysis process, and includes errors, warnings and progress messages. When an 

error message or warning relating to a particular object is written to the text 

output window, extra information is sometimes available by double-clicking on 

that line of text. 

../../../../Lusastranslations_Flare/English/FlareProjects/OnlineHelp/Modeller/Content/1using/Properties_panel.htm
../../../../Lusastranslations_Flare/English/FlareProjects/OnlineHelp/Modeller/Content/3geom/idh_merging_and_unmerging_features.htm
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Status bar 

 The Status Bar displays progress messages and help text during a modelling 

session, the model units, the current cursor position in model units (if the model 

is displayed in an orthogonal plane) and the item or number of items in the 

current selection. A view of the model can be obtained by pressing one of the 

primary axes shown in the status bar. 

General notes 

Within each View window, and within each Treeview, there is a current selection. In a 

Treeview there can only be one object selected at a time, and all commands are 

assumed to apply to it. In a View window several objects can be selected at the same 

time. Main menu and toolbar commands apply to whichever window was most recently 

clicked, either a View window or a Treeview panel. 

Some items within a Treeview support drag and drop functionality. Typically this will 

move them, copy them or connect them together within the treeview.  

Dragging an attribute from the Treeview onto selected objects in the View window 

assigns the selected attribute to the selected objects in that window. 

All the menus, toolbars, tree frame, text window, status bar and other similar windows 

can be resized, moved, made visible or invisible, and docked or separated from the 

main program window. LUSAS Modeller will remember their new location for the next 

time the program is run. Additional customization is possible - see the Modeller 

Reference Manual for details. 

Getting Help 

LUSAS contains a comprehensive Help system. The Help consists of the following:  

Most dialogs include a Help button which provides information on that dialog. 

Selecting Help > Help Topics from the main menu provides access to all the Help files.  

 If the Help Contents, the Help Index and the Search facility are not shown 

when a help page is first displayed pressing the Show button will show these tabs in the 

HTML Help Window.  
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